[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

nvidia (graphics) driver pain


I tried something along the lines of the recipe evoked several times
on this list, namely:

$ m-a build -t -u module-assistant -k source/linux-2.6.14 nvidia

Somewhere at the beginning of the log file:

  WARNING: Symbol version dump /home/eran/system/kernel/source/linux-2.6.14/Module.symvers
           is missing; modules will have no dependencies and modversions.

[Follows many warnings from the compilation.]

And this is the end of the log file:

  LD [M]  /home/eran/system/kernel/module-assistant/usr_src/modules/nvidia-kernel/nv/nvidia.o
  Building modules, stage 2.
/bin/sh: scripts/mod/modpost: No such file or directory
make[4]: *** [__modpost] Error 127
make[3]: *** [modules] Error 2
make[3]: Leaving directory `/home/eran/system/kernel/source/linux-2.6.14'
nvidia.ko failed to build!
make[2]: *** [module] Error 1
make[2]: Leaving directory `/home/eran/system/kernel/module-assistant/usr_src/modules/nvidia-kernel/nv'
make[1]: *** [build-stamp] Error 2
make[1]: Leaving directory `/home/eran/system/kernel/module-assistant/usr_src/modules/nvidia-kernel'
make: *** [kdist_image] Error 2

It seems that the compilation itself went OK (apart from the many warnings),
but there was a problem in "stage 2".  What's the problem?

I also tried with "make-kpkg", without better luck:

Module /home/eran/system/kernel/source/modules/nvidia-kernel failed.
Perhaps /home/eran/system/kernel/source/modules/nvidia-kernel does not understand --rootcmd?
If you see messages that indicate that it is not
in fact being built as root, please file a bug
against /home/eran/system/kernel/source/modules/nvidia-kernel.


Reply to: