[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Install on Sager np4750, Problems with Realtek r8169 ethernet driver

Hi everybody,
   I have a new Sager np4750 laptop that has a Realtek gigabit ethernet
card that uses the r8169 driver in the kernel.  On doing the amd64
install, Debian identified the card without problem.  I can load the
module and bring up the eth0 network interface.  However, I can't pass
any traffic, either by DNS or by IP address (I can't even ping my
gateway).  I get an error message "Netdev Watchdog: eth0: transmit
timed out".  I have tried building a new stock kernel (2.6.14) but the
result wasn't any different.
   I then tried building the driver as downloaded from Realtek's website,
but it failed to build.  I don't know if that problem pertains to the
driver's code, or simply with trying to build it for amd64 (sorry, this
is my first amd64 CPU -- so I'm new to 64 bit computing).
   Has anybody else had a similar problem with the r8169?  Should I first
try to install the 32 bit version of Debian to verify that it will work
in that version?  I guess I just don't know if this is just an r8169
driver problem, or a problem with it in the Debian amd64 port, or
something else.
   I have found some other linux users (Mandrake and Gentoo users) on the
web using this driver in the 64bit versions of their distro, without

Can anybody help?
Bryan Walton

Reply to: