[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: eth0: no link during initialization failure with Nvidia ethernet ports

On Tue, Jul 26, 2005 at 07:34:49PM -0600, John Schmidt wrote:
> I used Len Sorenson's install image -- sarge-amd64-2.6.12-netinst.iso on a 
> Tyan S2895 Thunder K8WE board.  This board has 2 onboard 802.3 Nvidia 
> ethernet ports.  I used the forcedeth module (version 0.32).  The eth0 port 
> registered the following error in dmesg:

Does ifconfig -a show that it found two ports on console 2?  Are you
sure you had the cable connected to the right one of the two ports?  You
never really know which order the driver assigns them in after all.

> eth0:  no link during initialization

Well either it is right and you had no link on whichever port it called
eth0, or the driver is broken.

> As a result of this failure, I couldn't complete the rest of the installation.  
> Everything up to the point of requiring 'net access worked fine with Len's 
> install image.
> I will probably look to getting some kind of pci ethernet card to put in this 
> box, that is unless some individual can point me to a solution to getting 
> eth0 up and running with the forcedeth module.  
> Any ideas about getting the onboard ethernet ports working or am I going to 
> have to go the route of getting some pci card.  And if so, suggestions on 
> good, well supported cards would be appreciated.

3c905, anything with a marvel yukon (3c990/dlink dge530/etc).  I
personally won't touch realtek chips which are found on most cheap

> Thanks Len for this install image.

Well I hope you figure out your ethernet ports.  I haven't tried it on
an nforce chipset myself, although I should try it on my wife's laptop
(nforce 250 go chipset) and see if it works on it.  Works fine on via
with marvell yukon chipset for gigabit at least.

Len Sorensen

Reply to: