[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: dchroot -d doesn't work

Marcin Dębicki wrote:

Leopold Palomo Avellaneda kiedys napisal:

are you running X and dchroot as the same user?
are the chroot enviroment working?
have you copied your shadow, passwd, group from 64 to 32 env?


A Dimarts 14 Juny 2005 17:58, Marcin Dębicki va escriure:
I am trying to run firefox under chroot

dchroot -d "firefox"

(ia32) firefox
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

(firefox-bin:21500): Gtk-WARNING **: cannot open display:
dchroot: Child exited non-zero.
dchroot: Operation failed.

Any ideas what is wrong?
Registered Linux User 369908
Yes it is already done. I've run xhost localhost but it didn't help.

Looks like DISPLAY is set to ":0.0". In this case X client will probably try
to connect to unix socket (which is prbably not there).
Try "export DISPLAY=" in combination with "xhost +"

I have
deleted all my previous 64 bit firefox settings but it didn't work. I've
tried to run it as root in chroot and it worked so I've just copied
settings generated for root and chown to my user. Now it works. I still
don't know what it was but it doesn't matter I think. Thanks for answer

Reply to: