[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: dchroot -d doesn't work

I had this problem recently with one of the users on the system. Found later
that i didn't have a recent copy of /etc/shadow /etc/passwd and /etc/group
in my chroot. The user didn't exist in the chroot so I was getting the same
error as the one you specify. Try copying those files over.

Hope this helps.


-----Original Message-----
From: Marcin Debicki [mailto:neo777n@poczta.onet.pl] 
Sent: Wednesday, 15 June 2005 6:35 AM
To: debian-x86-64@lists.debian.org
Subject: Re: dchroot -d doesn't work

Leopold Palomo Avellaneda kiedys napisal:

> are you running X and dchroot as the same user?
> are the chroot enviroment working?
> have you copied your shadow, passwd, group from 64 to 32 env?
> ......
> Regards,
> Leo
> A Dimarts 14 Juny 2005 17:58, Marcin Dębicki va escriure:
>> I am trying to run firefox under chroot
>> dchroot -d "firefox"
>> (ia32) firefox
>> Xlib: connection to ":0.0" refused by server
>> Xlib: No protocol specified
>> (firefox-bin:21500): Gtk-WARNING **: cannot open display:
>> dchroot: Child exited non-zero.
>> dchroot: Operation failed.
>> Any ideas what is wrong?
>> --
>> Registered Linux User 369908
>> alterfenix@jabberpl.org
Yes it is already done. I've run xhost localhost but it didn't help. I have
deleted all my previous 64 bit firefox settings but it didn't work. I've
tried to run it as root in chroot and it worked so I've just copied
settings generated for root and chown to my user. Now it works. I still
don't know what it was but it doesn't matter I think. Thanks for answer
Registered Linux User 369908

To UNSUBSCRIBE, email to debian-amd64-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact

Reply to: