[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bootsector not writable? [SOLVED]

Hi Cameron, hello list,

Am Montag, den 13.06.2005, 18:52 +0800 schrieb Cameron Patrick:

> > The system works without any problem if I boot it from my
> > grub-floppy.
> You could try installing grub from that boot floppy.  It'd be
> something like:
>   grub> root (hd0,0)
>   grub> setup (hd0)
> Replacing (hd0,0) with the partition that contains grub (e.g. /boot or
> if you don't have one, /).

OK, I tested this, and again, it seemes to work (setup reports no
errors) but in fact the system was still unbootable.

I decided to kill the MBR completely:

dd if=/dev/zero of=/dev/sda bs=446 count=1

Now, it is really gone ;)

I wrote an image with the MBR and the partition-table to my harddisk:

dd if=/dev/sda of=MBR_clean.img bs=512 count=1

I have tried to write the MBR again via grub-install and wrote the new
MBR to my harddisk:

dd if=/dev/sda of=MBR_new.img

OK, now I compared both images:

diff MBR_clean.img MVR_new.img

diff told me, that both files differ.

Fine, my assumption, that I have a problem to write the MBR was wrong ;(

I started again with digging into the BIOS options:
I have found an option "Prevent booting from IDE HDD" enabled.
As Linux uses an SCSI-devicefile (/dev/sda*) I thought that this option
has no effect. (This was the second wron assumption ;()

After diabling this option the system starts without a bootfloppy.

Sorry for that ;)

Thanks for all the help,

Reply to: