[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: vmware in 64 bit enviroment

Dr Gavin Seddon wrote:
> Hi,
> Vmware runs on a chroot.  But I want 64bit capability.  Some time ago I
> bought vmware 4.52 and according to their w-site it will run on amd64.
> So I tried to install.  All is ok until just after the header files bit.
> Then it fails to build vmmon.o.  I have tried to get a precompiled
> module to put into my running kernel.  No success.
If you try to build the modules inside your IA-32 chroot, it will fail,
unless you bind mount your kernel sources.  You'll still have to copy
the modules out though.

The better solution is to not install it in the chroot, but in amd64
mode.  You'll have to add your IA-32 libs to /etc/ld.so.conf and symlink
the 32-bit ld.so to /lib.  This is all covered in the howto.

As a warning, locale support will be broken and for me, highlighting any
text in the VMWare GUI and replacing it causes it to panic.  My guess
for this behavior from strace is that somehow a 64-bit X11 locale lib is
being dlopen'd() by a 32-bit app, which is obviously trouble.  I don't
know if this is a honset-to-god bug or a misconfiguration on my part.

The way around this is to install the system in the chroot, then cancel
the vmware-install.pl.  Symlink everything in the chroot to your amd64
install (using do_chroot for executables) and then run
vmware-install.pl.  Everything will function correctly then.

> The reason for wanting it running oon 64 bit is: I have a demanding win
> app that I need to run. 
It won't use the extra registers or anything, so I don't understand this
reasoning very much.  If it's anything but CPU intensive, running it in
VMWare will be several orders of manitude slower anyway.


Reply to: