[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Segmentation fault - grub 0.95+cvs20040624

> Hi
> I'm having some trouble with grub.  Briefly, when I installed orginally,
> I installed a 32 bit sarge system first and then the amd64 system, which
> has been working fine. For the sake of clarity we'll call this
> 64bit install 'production' I decided to use the 32bit sarge space to do a
> fresh amd64 system ('test') and I stupidly let the installer install grub.  Well
> apart from having to mount and edit the 'production' fstab, I managed to
> get back into my production system.
> But I've tried both grub-install and the grub command line interface:
> grub> root (hd0,7)
> grub> setup (hd0)
> setup (hd0)
>  Checking if "/boot/grub/stage1" exists... yes
>  Checking if "/boot/grub/stage2" exists... yes
>  Checking if "/boot/grub/e2fs_stage1_5" exists... yes
>  Running "embed /boot/grub/e2fs_stage1_5 (hd0)"...  16 sectors are embedded.
> succeeded
> Segmentation fault
> When I try to boot, I get:
> GRUB 1.5 (I think from memory)
> and then nothing ;(
> So it would appear that neither method is installing grub on the mbr
> Unfortunately, I don't have a floppy on this machine and so I have to
> repeat the 'test' install to get grub installed to the master boot
> record.  So the installer is successfully installing grub on the mbr.
> I've tried this a number of times but not making headway but before
> filing a bug report, I thought I'd check here first.

This is a known bug of grub, i had it 2 weeks ago. You won't be able
to install it by hand. I think it is a conflict with something in the
kernel as it only hapens with some versions of the kernel. For
example, with an "old" 2.6.6 grub works fine installing in the mbr,
but not for newer kernels like 2.6.8 or 2.6.10. You can download DFS
live-cd and try to install grub chrooting to you debian 64
installation. I thing DFS can boot with an amd64 ready 2.6.4 o 2.6.6

Aritz Beraza [Rei]
Aritz Beraza Garayalde [Rei]
[ WWW ]  http://evangelion.homelinux.net 
[jabber]  rei[en]bulmalug.net

Reply to: