[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Segmentation fault - grub 0.95+cvs20040624


I'm having some trouble with grub.  Briefly, when I installed orginally,
I installed a 32 bit sarge system first and then the amd64 system, which
has been working fine. For the sake of clarity we'll call this
64bit install 'production' I decided to use the 32bit sarge space to do a
fresh amd64 system ('test') and I stupidly let the installer install grub.  Well
apart from having to mount and edit the 'production' fstab, I managed to
get back into my production system.

But I've tried both grub-install and the grub command line interface:
grub> root (hd0,7)
grub> setup (hd0)
setup (hd0)
 Checking if "/boot/grub/stage1" exists... yes
 Checking if "/boot/grub/stage2" exists... yes
 Checking if "/boot/grub/e2fs_stage1_5" exists... yes
 Running "embed /boot/grub/e2fs_stage1_5 (hd0)"...  16 sectors are embedded.
Segmentation fault

When I try to boot, I get:

GRUB 1.5 (I think from memory)

and then nothing ;(

So it would appear that neither method is installing grub on the mbr

Unfortunately, I don't have a floppy on this machine and so I have to
repeat the 'test' install to get grub installed to the master boot
record.  So the installer is successfully installing grub on the mbr.

I've tried this a number of times but not making headway but before
filing a bug report, I thought I'd check here first.



www.clivemenzies.co.uk ...
...strategies for business

Reply to: