[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: installing on XFS: bootloader problem

Max <relf@unn.ac.ru> writes:

> Hello!
> I'm trying to install debian-amd64 to my existing xfs partition /dev/hdb2 (so it's on the second HDD while my main system lives on the first HDD with LILO on MBR).
> First, I downloaded sid-amd64-netinst.iso, burnt a CD and boot from it. Everything went just fine until installing bootloader stage. From GRUB I got a warning
> The GRUB bootloader installation often fails or hangs when /boot is on XFS filesystem. Using LILO in this situation is recommended.
> So I went for LILO. Unfortunately, it failed to install saying "/sbin/lilo failed with error code 1".
> I tried to install it manually from command shell running
>   chroot /target /sbin/lilo
> but it reported a fatal error:
> Fatal: Filesystem would be destroyed by LILO boot sector: /dev/hdb2

You have to install lilo in the MBR. But you already have one there so
the best course of action is install without bootloader and then copy
the amd64 kernel and initrd over to your i386 /boot and add them to
lilo there.

> (That's weird! Why GRUB suggests to use LILO on XFS while LILO shows total incompatibily???)
> So I decided to give a try to GRUB. First, I tried to replace existing LILO in MBR at /dev/hda replacing. It failed with no obvious reason (LILO well survived, btw).
> Then I tried to install it directly into /dev/hdb2 and got it hanging up at 50% done. After reset I was forced to repair XFS partition zeroing its log due to severe damages.
> So, what is a proper way to install bootloader on XFS?
> And where should I report existing problem?

grub-installer / lilo-installer.

> Thanks,
> Max


Reply to: