[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

2.6.10 smp kernel locks up on boot

I've just done a new pure64 installation on my dual Opteron using 19-02-2005 
netinst. This went smoothly until I tried to upgrade to the current 
2.6.10 smp kernel (kernel-image-2.6.10-9-amd64-k8-smp_2.6.10-4_amd64.deb). 
It caused a lockup on first reboot with the following message:

modprobe [909] trap invalid operand rip: 2a956ea248 rsp: 7fbffff818 error: 0
NMI Watchdog detected LOCKUP on CPU0CPU 0
Modules linked in: ext3 jbd mbcache

Subsequent hard reboot caused a lockup without the first line of the
above message. In both cases the lockup followed a long list of error
messages regarding various modules, eg.
ERROR: Removing 'trm290': Device or resource busy
There were so many of these they scrolled off the screen.

I then tried an earlier version of this kernel which I had saved on a CD
(kernel-image-2.6.10-9-amd64-k8-smp_2.6.10-2_amd64.deb) and it works fine.

A diff shows no difference between the kernel configs except the
earlier one has CONFIG_INPUT_MOUSEDEV_PSAUX_ENABLE=y and the new one doesn't
contain this line.

The motherboard is MSI K8T Master2 FAR (VIA K8T800/VT8237) with
2 x Opteron 240, 2 x 512MB RAM with chip-kill ECC enabled.

Anyone got any ideas why this is happening?


Reply to: