[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Time to test sarge

the owner <editor@postscript.port5.com> writes:

> Goswin wrote:
>>> I used the above sources.list with this image:
>>> sid-amd64-netinst.iso    11-Feb-2005 09:01   193M Maybe that is the
>>> wrong image to test the debian-pure64 testing. After reboot the
>>> base config did not allow manual package selection.
> I tried again and base config failed again on file server config and
> manual package config. This could be the same problem as below.

I don't understand what you mean here. I guess I have to see it with
my own eyes. I suspect some deb is stuck the upload queue that
base-config needs or something. An error for this just flashes by and
is hard to spot or actualy read what is missing.

>>> I exited the base config and tried dselect and there were conflicts
>>> with dependency on libc6. The libc6-dev depends on libc6 =
>>> 2.3.2.ds1-20 and libc6 was version 2.3.2.ds1- I
>>> think that would be fixed in a day or two.
> I think everything will work after sarge is updated to yesterdays sid.

No, patched sources/debs don't enter sarge (not automatically, not yet).
This needs manual fixing, see below.

>> I can't figure that one out:
>> apt-cache policy libc6 libc6-dev
>> libc6: 2.3.2.ds1-20 0 1001 http://debian-amd64.alioth.debian.org
>> sarge/main Packages libc6-dev: 2.3.2.ds1-20 0 1001
>> http://debian-amd64.alioth.debian.org sarge/main Packages
>> Only sid has 2.3.2.ds1- which only differs in having a
>>  Replaces: base-files (<< 3.1.2- for update purposes.
>> Could you try the libc6/libc6-dev again though and check with
>> apt-cache policy where it comes from?
>> MfG Goswin
> +++++++++++
> I really think I used a netinst image that was too new. The libc6 must
> have come from sid in the sid-amd64-netinst.iso and conflicted with the
> Packages in testing. I think I should have tried sarge-amd64-netinst.iso
> because the 11 Febuary unstable sid must be ahead of testing sarge.

Ahh, right. That is the case.

I'm plaing to downgrade the sid libc6 to an unpatched form to fix
this. The patch was only needed for upgrades and hopefully everyone
has done so now. Any objections?


Reply to: