[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Abit AV8: can't set DMA on cd/dvd, but can with Ubuntu live

Did you try disabling generic IDE support in the kernel configuration? Check http://ck.kolivas.org/audio_hints.txt .


Ric Otte wrote:

I have an Abit AV8 that works well except that I'm unable to set DMA on my
cd/dvd drive.  Whenever I try hdparm -d1 /dev/hda (sata hard drive, so cd is
hda), I get the following:
     setting using_dma to 1 (on)
    HDIO_SET_DMA failed: Operation not permitted
    using_dma    =  0 (off)
During startup there is also a message about trying and failing to start DMA
on it, but it flies by rather fast and I can't reproduce it here (it isn't in
dmesg).  I tried making a script in /etc/init.d that would set the DMA, but
that didn't work.  I believe the relevant part of lspci -v is:
    0000:00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06) (prog-if 8a [Master SecP PriP])
        Subsystem: ABIT Computer Corp.: Unknown device 1415
        Flags: bus master, medium devsel, latency 32, IRQ 20
        I/O ports at d400 [size=16]
        Capabilities: [c0] Power Management version 2
and under lsmod I have "via82cxxx              14064"  1 listed.  I'm using
kernel 2.6.10.

So I put in the Ubuntu AMD64 Hoary live cd and booted off of it.
Surprisingly, I was able to set DMA on the cd/dvd drive.  So I copied
their .config file of the kernel and /etc/modules.  I recompiled my
kernel with only two changes (amd64 instead of generic, no rivafb),
and added anything in their /etc/modules to mine.  But I still can't
set DMA, although I can still set it from the live cd.  This really
baffles me.

Has anybody been able to set DMA on an optical drive with this
motherboard, have any suggestions, or know why I can set it with
Ubuntu but not with Debian?  Thanks,


Javier Kohen <jkohen@fibertel.com.ar>
ICQ: blashyrkh #2361802
Jabber: jkohen@jabber.org

Reply to: