[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

problem running Xprint on amd64 (x86-64)



One of my Debian users has experienced some problems running Xprint on
amd64 (x86-64).

Originally he was getting a segfault
(http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=278510)

He now reports the segfault is no longer occuring, after release of a
newer Debian revision.  Since it's still the same Xprint v9.001, I
presume the change has been in libc6 or some other library for amd64
(not that libc6 has changed for amd64 over this time, but anyway.  Maybe
they use gcc-3.4 instead of gcc-3.3?).

However, he reports that Xprint is nevertheless still not working,
although it is no longer segfaulting:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=282655&repeatmerged=no
Xprt is running, but /etc/init.d/xprint thinks it has stopped.


Since the original bug was specific to amd64, it occurs to me that the
second might be as well.  But the error is happening
in /etc/init.d/xprint, not in Xprt.


Support for amd64 is still "under development", it's not yet "fully
supported" by Debian.  So I'm not sure how much of his troubles are due
to bugs in standard libraries (libc etc) for amd64, and how much could
be Xprint's.

The problem is not clear enough for me to file an Xprint bug.  But I
thought it might be useful to raise it on the mailing list for further
thought.


Debian amd64 porters - can any of you confirm that Xprint (package
xprt-xprintorg) is working successfully for you?  Test with xphelloworld
or by printing from mozilla.



Regards,

Drew Parsons



Reply to: