[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Kernel panic 2.6.8-9, unable to boot at all

John C. Martin wrote on 2004-10-30 16:42:
Is the driver for the root filesystem device modularized in your kernel?

Yes, it is modularized. This being the 3ware card, it is part of the
kernel for a very long time.

I just found something somewhat odd while checking if they were
actually both modularized in the config-xxxxxxx files in /boot

Yes, they are both modularized. But, since my card is 3ware,
I am not sure if my culprit isn't in these two lines

config for kernel 2.6.7-5

config for kernels 2.6.8-1..2.6.8-9

Now... A couple of days ago I asked the 3ware people about
their raid manager stuff for debian, and here is a part
of their reply:

  We are planning to phase these in to the 8000/7000 series
  in the next release. Make sure the controller has the latest
  firmware and driver.

I wonder if having the 2 modules in is what screws up things.

I had the same thing here last week on my systems (Shuttle SN95G5). The driver module supporting the device the root filesystem was on was not being loaded. The problem was solved by explicitly adding the module to /etc/mkinitrd/modules and rebuilding the initrd image (using a full kernel rebuild, I could not get mkinitrd to work for me standalone). I had to fall back to previous kernel I was using (2.6.6) to boot, make these changes, and rebuild the kernel.

I added '3w-xxxx' (the module I need) to /etc/mkinitrd/modules

With that, I tried to login, but ended up with the same kernel panic stuff.

Now... Do I need a kernel compilation? If so, how on earth can I do
that --I can't even login...

BTW, since I am using stock Debian kernels, is there anywhere I can
download those images from. I might as well try that --easier than
setting up a fresh install, I guess.


Reply to: