[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Beginner question about pure64 vs. sarge vs. gcc3.4

Steffen Schwigon wrote:
> [ I'm new to 64bit, but read amd64 HOWTO and the like ]


> I want to setup a Debian/Sarge-like system on my Athlon64fx. I tried
> an install of "sarge" with a Debian-Installer-CD. The install itself
> looked good, but it couldn't write a correct boot loader, neither GRUB
> nor LILO. The MBR became corrupted.

That does not sound good.  But it looks to indicate a problem.  Why
couldn't it write the MBR?  If there was a failure then that is bad.
But since the installer is used by many people successfully I don't
think there is a problem there.  More likely something on your end.

> The questions:
> 1. Is the recommended method an installation via bootstrapping
>    into a chroot based on a classic 32bit system?

No.  If you install in a 32-bit system you end up with a 32-bit
system.  You *must* use a 64-bit kernel to install the 64-bit system.

There are two "recommended methods".  One is to use the
debian-installer as you mentioned that you did.  The other is to use
debootstrap and to run the same thing the debian-installer does but
instead run those manually.  This gives finer grained control.  But
the end result should be basically the same.

>    (The Installer ran good, maybe I just forgot something. The 32bit
>    installer installed GRUB without problems.)

I am wondering if perhaps the amd64 debian-installer you used was a
bad snapshot.  I suggest trying a different snapshot from a different
day.  Things are not completely stable.  Some things are broken from
day to day.

> 2. After the broken MBR, I wanted to boot from the install CD with
>    parameter "root=/dev/...". That didn't work. I tried different
>    names: /dev/hda6, /dev/sda6, /dev/discs/disc0/part6, but always get
>    kernel panic "Unable to mount root fs".

Once you have booted look at /proc/partitions to see what is available
to mount.  Just thrashing around is not very efficient.

The error "Unable to mount root fs" is almost always a problem with
the modules loaded in the initrd (initial ram disk) image.  Make sure
that was loaded correctly too.

I would use the DFS disk mentioned in the howto.  It boots grub.
There you can specify these parameters at boot time.

>    Is this possible in any way? It seems to need some modules for my
>    SATA harddisc. So maybe it won't work with the kernel on CD.

It definitely should work for you.  It works for me on my SATA
system.  I am more concerned about the errors you mentioned when
installing.  That should not happen.  So I think the root of the
problem lies there.


Reply to: