[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

SATA/usb mass storage conflict

I have tried installing the amd64 port and I was able to install and
configure the base system once but after this it times out when checking the 
partitions on the drive ( i.e. /dev/scsi/host0/bus0/etc. p1 p2 <p5> etc.) on
reboot. I've also tried rerunning the installer and it times out at
loading sd_mod.

After much frustration I gave up on the installer and tried the
installer from fedora core 2 for amd64 thinking I might be able to try
with a different kernel and it was freezing when loading the usb mass
storage drivers ( I have a usb flash reader installed instead of a
floppy). Disabling usb allows me to boot the fedora core installer but
still not the debian installer ( hanging at sd_mod) and of course the
initrd image on the hd is loading the usb mass storage drivers and failing 
with the same time out as before.

Is there a simple way to remove the drivers for usbms from the initrd
image while using the fc rescue disk? Has anyone had similar
experiences? I'm assuming the sata drives and the usb drives are
fighting over /dev/sda, if I were to create a kernel image with the sata
drivers compiled in statically and the usbms loaded as a module later
do people think it will still conflict?

Reply to: