[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Audio problems with Asus K8V SE Deluxe

I had a problem with sound just not working, and it had something to do with the kernel loading up the OSS drivers as well, which interfered with the ALSA drivers. perhaps you have something similar? I cant remember what the oss driver looks like when using lsmod, off the top of my head, it may have been sound*.

Sorry not very helpful, but hopefully it helps.

p.s. maybe broken Mboard?

Cheers - Nick

Eric Sharkey wrote:

Does anyone have audio working correctly on an Asus K8V SE Deluxe?

I recently upgraded the motherboard on my desktop at home to this
board and am having trouble getting audio to work correctly.
The motherboard has an integrated VIA VT8237 audio chip on it,
and it sort-of works with the ALSA VT82xx driver, but not very well.
Some things seem to sound ok (xmms) but others don't (nearly everything
else I've tried).  The sound is irregular, with pops and crackles,
random large fluctuations in volume, and runs at the wrong speed
(usually too fast).

I've searched the web/usenet and found that I'm not the only one
with this problem:

 From: Rod Smith (rodsmith@nessus.rodsbooks.com)
 Subject: Re: athlon64 upgrade ...
 Newsgroups: comp.os.linux.hardware
Date: 2004-05-27 16:54:03 PST

 the VIA VT8237 that drives it is not yet officially supported by
 the kernel, although it does work with the ALSA VT8233 driver --
 just not optimally. Specifically, some programs produce sped-up
 or "stuttery" sound.



But I've also read that this is supposed to be fixed as of ALSA
1.05a (I've installed modules compiled from Debian's alsa-source

Now, here's where it gets weird.  I decided to just disable the
onboard audio and install a pci sound card (Trident 4DWaveNX)
since this chip has been around for several years and is very well
supported by ALSA.  After switching to the new card I expected the
problems to go away, but they persist.  This happens both with the
analog output and the SPDIF out, so it's not just analog noise.

I've been running stock i386 Debian sid with a vanilla Linus Linux
2.6.8 compiled 32-bit but optimized for Athlon64.

I've tried twiddling several of the kernel settings (APIC, ACPI,
CPU Frequency scaling, pre-emption) and lots of compiles/reboots
later I've yet to find a setting that does not have this problem.

Does anyone have any suggestions?


Reply to: