[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Glibc with NPTL


Thanks the patch works great.


Andreas Jochens wrote:
On 04-Sep-09 14:39, Daniel Malmkvist wrote:

I really want to use NPTL and I don't think I use it right now. I tried a small JAVA program that generated a lot of threads and the all showed up as separate process, like with linuxthhreads ( used Blackdowns port of Suns JVM for AMD64). I tried the same method on a 32 bit system (debian sarge) and then the threads runs in one process like it should. Is there any simpler way to see if Glibc is NPTL enableed?

Anyway how do I do to enable NPTL. I downloaded the glibc source package and made sure that ?GLIBC_PASSES += nptl? was included in debian/sysdeps/amd64.mk but it diden't seem to work.

What am I doning wrong, is there anyone that already have glibc packages that are NPTL enabled?

The amd64/gcc-3.4 archive (http://debian-amd64.alioth.debian.org/gcc-3.4) uses a glibc package which exclusively uses NTPL (not in addition but instead of the old linuxthreads that need only be used with 2.4 kernels which are not supported by the amd64 port). The pure64 archive still uses linuxthreads (there is an extra nptl pass in glibc but the resulting library is not used as the default).

You can look at the latest glibc patch in http://debian-amd64.alioth.debian.org/gcc-3.4/patches to see how debian/sysdeps/amd64.mk can be changed to use NPTL instead of linuxthreads. That patch does not create an extra nptl pass. It uses nptl for the main libc pass instead of linuxthreads.

Andreas Jochens

The above information is confidential to the addressee and may be
privileged. Unauthorised access and use is prohibited. Internet
communications are not secure and therefore this Company does not accept
legal responsibility for the contents of this message. If you are not the
intended recipient, any disclosure, copying, distribution or any action
taken or omitted to be taken in reliance on it, is prohibited and may be

Reply to: