[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problems etc. when installing pure64


Yesterday, I got a brand new amd64 machine in the office. Cool.
It has the following CPU:

$ cat /proc/cpuinfo
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 12
model name      : AMD Athlon(tm) 64 Processor 2800+

I am running the following kernel:

$ uname -a
Linux setup-4 2.6.7-5-amd64-k8 #1 Thu Jul 15 01:13:32 CEST 2004 x86_64 GNU/Linux

Below, I try to list some of the problems I had during install.

- The link to "Documentation (FAQ and HOWTO)" on
  http://www.debian.org/ports/amd64/ is broken. It points to
  https://alioth.debian.org/docman/?group_id=1314 instead of

- Netboot did not work. I got an error message "can't open an
  initial console" after the kernel came up. Then it crashed.

  It took me quite some time to find out what the problem was. 
  It turned out that the initrd image from the netboot was
  broken. I try to show you what is broken and how I fixed it.

  I got the netboot stuff from
  ( the dates of the files are August 7, 2004, so I guess this
    is http://debian-amd64.alioth.debian.org/debian-installer/2004-08-07/netboot/2.6/ )
  # gunzip initrd.gz
  # mount -o loop initrd /mnt
  # cd /mnt/dev
  # ls -l
  total 0
  -rw-rw-rw-  1 root root 0 Jan  1  1970 console
  -rw-rw-rw-  1 root root 0 Jan  1  1970 null

  Of course, this is not correct.

  # ls -l /dev/console /dev/null
  crw-rw----  1 root root 5, 1 Aug 11 13:53 /dev/console
  crw-rw-rw-  1 root root 1, 3 Aug 11 13:53 /dev/null
  # rm -f console ; mknod console c 5 1 ; chmod 660 console
  # rm -f null ; mknod null c 1 3 ; chmod 666 null
  # ls -l
  total 0
  crw-rw----  1 root root 5, 1 Aug 11 15:41 console
  crw-rw-rw-  1 root root 1, 3 Aug 11 15:41 null
  # cd -
  # umount /mnt
  # gzip initrd
- I have the following graphics card:

  0000:01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5200] (rev a1) (prog-if 00 [VGA])
        Subsystem: LeadTek Research Inc.: Unknown device 53c3
        Flags: bus master, 66MHz, medium devsel, latency 248, IRQ 16
        Memory at fb000000 (32-bit, non-prefetchable) [size=16M]
        Memory at f0000000 (32-bit, prefetchable) [size=128M]
        Expansion ROM at faf00000 [disabled] [size=128K]
        Capabilities: [60] Power Management version 2
        Capabilities: [44] AGP version 3.0

  and a "Eizo FlexScan L767" with a DVI cable. The monitor only
  showed green or purple or blue snow instead of a gdm login
  screen after installing xserver-xfree86. I had to install the
  binary driver from NVidia to get a usable picture under X. The
  text console worked from the beginning. I have only hacked the
  nvidia-graphics-drivers source package to build it for amd64
  (including the driver from NVidia) but would be willing to
  share this with other if there is interest.

Philipp      | work: pfrauenf@math.ethz.ch  +41 44 632 60 38
Frauenfelder | home: pfrauenf@debian.org    +41 44 862 73 14
[PGP]        | http://www.math.ethz.ch/~pfrauenf/
Proudly running Debian GNU/Linux. See http://www.debian.org/

Attachment: signature.asc
Description: Digital signature

Reply to: