[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Booting, grub & x86_64 kernels.

Greetings all.

I have an installation of Debian-amd64, upon which I have compiled (a bunch of) kernels. My problem is that I am trying to get grub to boot these new kernels. It won't.

I've compiled hundreds of kernels on 32 bit that usually worked fine.

My x86_64 kernels boot only up to a point, then they fail with the messages like: can't mount root partition ... can't find partition ... initrd.img too big and another that is something like: please append a proper "root=" boot option.

Naturally I've compiled a several monolithic kernels and many with different module configurations ... point is I've done every darn thing I can think of ... even read man pages ... %^) One monolithic booted, but ran so slow, it was useless.
I've tried lilo as well, no go.

My questions are: Is there a source I can study that deals with booting personally compiled x86_64 kernels with grub ... and ... does the 64 bit kernel need an initrd.img to boot?

I have been using Linux-2.6.7 from kernel.org,
I have a Asus K8V
1 gig mem module.

Thank you for any ideas,
Chris w.

Reply to: