[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Disk quota not working with 64bit kernel, 32 bit userland.

>XFS mounting filesystem md0
>Ending clean XFS mount for filesystem: md0
>XFS quotacheck md0: Please wait.
>XFS quotacheck md0: Done.
>This "md0" is my RAID0 device.
>But, then when it goes to actually turn on quotas I get:
>quotaon: 32bit quotactl not supported on 64 bit kernel
>Any subsequent attempt to use quota tools also result in a similar
>message sent to /var/log/messages.

We're basically seeing the same messages on our dual-opteron
server. Could anybody knowledgeable please comment on this?
Is quota just not (yet) working for amd64? Are any patches for 
the quota source itself required? I think I tried all possible
kernel config switches so far but still no luck. :-/

kernel: 2.6.2 and currently 2.6.5, woody (64bit kernel, 32 bit userland)

Any help/hints appreciated...

Lars Wessels

Lars Wessels 
Institut fuer Wirtschaftspolitik und Wirtschaftsforschung (IWW)
Universität Karlsruhe (TH)
Tel: 0721 608 4780 Fax: 0721 607376
E-Mail: wessels@iww.uni-karlsruhe.de

Reply to: