[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Making /pure64 image bootable

In /boot/grub/menu.lst:

Change to:

# kopt=root=/dev/hde28 ro

# groot=(hd1,27)

Then update-grub automatically sets the boot-device and kernel correct.

Best Regards

Toshikazu Aiyama, Ph.D. wrote:

Hi Anders,

Thank you for your quick and many replies.

I also prefer lilo over grub - but I'd only found
packages for grub and
palo - so grub was the easiest solution. And it
seemed like lilo only
was usable on 32-bit - perhaps I'm wrong?

I have downloaded lilo-installer_0,40_amd64.udeb.  Is
it not 64-bit?

Is your /dev/hde28 bootable/active? I know that
Debian-Installler which
default uses grub has problems with some

I use my own-developed less than 510 bytes boot manger
which simply reads in boot record from any drive's any
partition.  If you are interested in, it is at

I also compiled x86_64 kernel for dual opteron and for
my SATA controller.

Perhaps you should try using (I asume that you are
using a controller
and don't have any harddisks  on hda hdb hdc or hdd
so hde will be
(hd0)- right?):

# grub-install (hd0)

What does the machine say when you boot - 'GRUB'

I edited device.map and tried
  # grub-install (--force-lba) /dev/hde(28)
produces messages of:
The file /boot/grub/stage1 not read correctly

It simply beeps since it is not bootable partition.  I
designed my boot manager beeps when it is not

Regarding udeb-files:

I know you can extract udeb's with dpkg, perhaps dpkg
can install
as well ?

I have tried
  # dpkg -i lilo-installer_0.40_amd64.udeb
produces message of:
dpkg-deb: `lilo-installer_0.40_amd64.udeb' is not a
debian format archive
dpkg: error processing lilo-installer_0.40_amd64.udeb
subprocess dpkg-dev --control returned error exit
status 2

Thanks for reporting back. I will try some tests to
find out, how the
README needs to be updated, I'm working on a test
environment :-)

I have also noticed all off those new packages :-) So
I'm working on an
update as well - Thanks :-)

I must express many thanks to you.  You have done a
good job.

How do you find the idea of using mini.iso - it has a
lot of usefull
packages and it boots great - at least on mine.

I have built dual opteron machine based on Tyan's
Tiger k8w which has Sii3114 SATA controller which
mini.iso fails to recognize.  This SATA controller is
used in many amd64 M/B, and I wonder why it is
compiled in the installer's kernel. I do have hda, but
I must use it for other purpose.

Again, thank you for all of you people effort.  I am
somewhat enjoying
amd64 assembly language programming using YASM.

Toshikazu Aiyama, Ph.D.

Do you Yahoo!?
Win a $20,000 Career Makeover at Yahoo! HotJobs http://hotjobs.sweepstakes.yahoo.com/careermakeover

Reply to: