[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Making /pure64 image bootable

Toshikazu Aiyama, Ph.D. wrote:

Hi Anders,

Thank you for your quick and many replies.

I also prefer lilo over grub - but I'd only found
packages for grub and
palo - so grub was the easiest solution. And it
seemed like lilo only
was usable on 32-bit - perhaps I'm wrong?

I have downloaded lilo-installer_0,40_amd64.udeb.  Is
it not 64-bit?

It should be pure64. I couldn't find that package, but tried to install lilo from source. I also found a page at RedHat claiming that only grub and not lilo is available for AMD64.

When performing a QuickInst I get an make error.

Is your /dev/hde28 bootable/active? I know that
Debian-Installler which
default uses grub has problems with some

I use my own-developed less than 510 bytes boot manger
which simply reads in boot record from any drive's any
partition.  If you are interested in, it is at
Interessting - What is the major difference between this and eg. lilo's MBR?

I also compiled x86_64 kernel for dual opteron and for
my SATA controller.

Perhaps you should try using (I asume that you are
using a controller
and don't have any harddisks  on hda hdb hdc or hdd
so hde will be
(hd0)- right?):

# grub-install (hd0)

What does the machine say when you boot - 'GRUB'

I edited device.map and tried
  # grub-install (--force-lba) /dev/hde(28)
produces messages of:
The file /boot/grub/stage1 not read correctly

I have setup an test-environment and got the same message. Found this explanation:

"> The file /boot/grub/stage1 not read correctly.

This an error message from the grub-install script when it verifies
whether the boot loader images read by GRUB itself are the same than
as read by your operating system from local file-system. If you have
specified a wrong GRUB root device or GRUB reads wrong data due to
geometry mismatch or anything like that, the sanity check fails."

Got it to boot after editing /boot/grub/menu.lst manually - I think it point to the wrong partition. It has something to do with default options in menu.lst. Anyway:

1) Manually edit /boot/grub/menu.lst - root and kernel.

2) Run grub as in README

3) Reboot

It simply beeps since it is not bootable partition.  I
designed my boot manager beeps when it is not

Regarding udeb-files:

I know you can extract udeb's with dpkg, perhaps dpkg
can install
as well ?

I have tried
  # dpkg -i lilo-installer_0.40_amd64.udeb
produces message of:
dpkg-deb: `lilo-installer_0.40_amd64.udeb' is not a
debian format archive
dpkg: error processing lilo-installer_0.40_amd64.udeb
subprocess dpkg-dev --control returned error exit
status 2

Haven't been able to find any lilo-packages.

Thanks for reporting back. I will try some tests to
find out, how the
README needs to be updated, I'm working on a test
environment :-)

I have also noticed all off those new packages :-) So
I'm working on an
update as well - Thanks :-)

I must express many thanks to you.  You have done a
good job.

How do you find the idea of using mini.iso - it has a
lot of usefull
packages and it boots great - at least on mine.

I have built dual opteron machine based on Tyan's
Tiger k8w which has Sii3114 SATA controller which
mini.iso fails to recognize.  This SATA controller is
used in many amd64 M/B, and I wonder why it is
compiled in the installer's kernel. I do have hda, but
I must use it for other purpose.

So if it is compiled into the kernel it don't get used, and claims it can't be loaded.

Again, thank you for all of you people effort.  I am
somewhat enjoying
amd64 assembly language programming using YASM.

Toshikazu Aiyama, Ph.D.

Do you Yahoo!?
Win a $20,000 Career Makeover at Yahoo! HotJobs http://hotjobs.sweepstakes.yahoo.com/careermakeover

Best Regards

Reply to: