[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: 64bit perl

On Mon, Apr 19, 2004 at 12:25:50AM +0200, Kurt Roeckx wrote:
> On Sun, Apr 18, 2004 at 10:54:52PM +0200, Lionel Elie Mamane wrote:

>> I just installed a pure64 chroot, and I noticed that perl,
>> perl-modules, etc are missing.

> apt-get install perl worked perfectly for me.

I must not have the right sources.list then. I have

deb ftp://bytekeeper.as28747.net/amd64/jgoerzen/amd64 sid main
deb http://people.debian.org/~jgoerzen/amd64/ sid main

And there, there is only perl-base. Perl is there, but it depends on
perl-modules, which is missing, and is thus uninstallable.

>> So, I tried to compile the perl source package, and I've seen it fails
>> to handle floating-point numbers.

> What version are you trying to compile?


> What version of the Build-Depends?

ii  file                 4.07-2               Determines file type using "magic" numbers
ii  cpio                 2.5-1.1              GNU cpio -- a program to manage archives of files.
ii  libdb4.0-dev         4.0.14-1.3           Berkeley v4.0 Database Libraries [development]
ii  libgdbm-dev          1.8.3-2              GNU dbm database routines (development files)
ii  netbase              4.16                 Basic TCP/IP networking system
ii  gcc                  3.3.2-3              The GNU C compiler

and the build-essentials:

ii  libc6-dev            2.3.2.ds1-11         GNU C Library: Development Libraries and Header Files
ii  gcc                  3.3.2-3              The GNU C compiler
ii  g++                  3.3.2-3              The GNU C++ compiler
ii  make                 3.80-6               The GNU version of the "make" utility.
ii  dpkg-dev             1.10.18              Package building tools for Debian

> I think I did have some other problems because of other reasons not
> related to the package at all. I think one of them was not having a
> "search" in /etc/resolv.conf. And the other not having the hostname
> in /etc/hosts.

I'm willing to try, but I'd be surprised that not having a /etc/hosts
gets Perl to barf on floating point numbers :)


Reply to: