[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [biarch] mysql-client vs. perl

Eric Sharkey writes:
 > Actually, I meant "apt-get install libdbi-perl", not really dropping
 > all the way down to the level of dpkg.

biarch:~# apt-get install libdbi-perl
Reading Package Lists...
Building Dependency Tree...
Sorry, libdbi-perl is already the newest version.
You might want to run `apt-get -f install' to correct these:
Sorry, but the following packages have unmet dependencies:
  libdbi-perl: Depends: perlapi-5.6.1
  mysql-client: Depends: libdbd-mysql-perl (>= 1.2202) but it is not going to be installed
                Depends: libreadline4 (>= 4.3-1) but 4.2a-5 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Doing "apt-get -f install" just removes the unpacked libdbi-perl and
mysql-client packages.

 > perlapi-5.6.1 is a virtual package provided by perl-base.
 > What's your dpkg --status on perl-base?

biarch:~# dpkg --status perl-base
Package: perl-base
Essential: yes
Status: install ok installed
Priority: required
Section: base
Installed-Size: 1784
Maintainer: Brendan O'Dea <bod@debian.org>
Source: perl
Version: 5.8.0-18
Replaces: perl-5.005-base (<< 6), perl-5.6-base (<< 6), perl (<< 5.8.0-9), perl-modules (<< 5.8.0-9)
Provides: perl5-base, perlapi-5.8.0, data-dumper
Pre-Depends: libc6 (>= 2.3.1-1)
Suggests: perl
Conflicts: perl-5.004-base (<< 6), perl-5.005-base (<< 6), perl-5.6-base (<< 6), data-dumper, autoconf2.13 (<< 2.13-45)
Description: The Pathologically Eclectic Rubbish Lister.
 A scripting language with delusions of full language-hood, Perl is used
 in many system scripts and utilities.
 This is a stripped down Perl with only essential libraries.  To make
 full use of Perl, you'll want to install the `perl', `perl-modules' and
 optionally `perl-doc' packages which supplement this one.

It provides perlapi-5.8.0, not 5.6.1.  Which Perl version is correct?



Reply to: