[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

5.17.0 boot issue on Miata

When I attempt to boot a 5.17.0 kernel built from the kernel.org
sources, I see disk sector errors on my "sda" device, and the boot
process hangs at the point where "systemd-udevd.service" starts.

Rebooting on 5.16.0 works with no disk I/O errors of any kind.

Assuming the 5.17.0 kernel or its associated initrd had bad sectors, I
rebuilt both and saw no I/O errors during the build nor afterward when
copying the new kernel into place under "/boot".

Even tried a cross-compile build of a 5.17.0 alpha kernel on my x86_64
platform to save build time (34 hours for a native build on a PWS 433au
vs. 2 hours on the x86_64 platform).  That build produced identical
results when I tried booting on it.

If anyone else is seeing this and can get a head-start on bisecting,
that would be very much appreciated.  I won't be able to get to it for
about a week and a half :-(.  5.16.0 works.  5.17.0 doesn't.  Might get
lucky and find that the offending changes happened in the first 5.17.0
release candidate.

As always, sincere thanks in advance.


Reply to: