[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: xorg 7.0 and Radeon 7500

rct wrote:
> Donsbach, Jeff wrote:
> >  
> > Fwiw, the Gentoo alpha port skipped over 7.0 and just recently marked
> > 7.1 as "stable". (I'm not sure why 7.0 was skipped over). So, maybe
> > there would be some merit in trying out 7.1 .
> As soon as the 7.1 packages are available (experimental or unstable),
> I'm all over that suggestion...  Disk space is an issue as far as
> building from source, unless the new modular architecture implies I
> don't need to build the entire X11 world to try selected pieces of 7.1.
> Update: filed a bug report (#7567) against the fbdev driver at
> bugs.freedesktop.org back on the 19th.  No response thus far.

Update: still no response from the freedesktop people after nearly two
months.  That's service :-(.  As far as what I've been able to try on my
own in the interim, this week I upgraded all the xorg packages to the
latest available in the "unstable" series (7.0.23 and friends).  Everything
is still broken, only worse...  I used to be able to fire up the fbdev
server and get a blank screen, but the keyboard and mouse input devices
would still work, i.e., I could switch to a virtual console and the system
was evidently fine otherwise.  Current status: X starts, the display blanks,
and the system locks up solid -- can't even login remotely.  Console keyboard
unresponsive.  The Xorg.0.log file contains the normal expected output,
and only two obvious error messages -- "FBIOBLANK: Invalid argument", and
a message about the xserver not being able to open the SecurityPolicy file.

As a sanity check, I'll probably pull the Radeon and put the old tga2 back
in place.  8-bit depth is better than nothing.  Only trouble is, I've not
tried anything substantially more recent than the "Sarge" X11 packages with
that card, so success isn't guaranteed.  If the tga2 *does* work, I'll
interpret that as a good sign...

Wishlist item: if some nice person would build and upload xorg 7.1 + video
driver packages for Alpha to the "experimental" hierarchy, I would be more
than pleased to give 'em a try.  At the moment, only the x86 people are
being allowed onto the playground :-).

Bob Tracy                   WTO + WIPO = DMCA? http://www.anti-dmca.org

Reply to: