[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Kernel 2.6 and SMP


does anyone successfully run a kernel 2.6 on an SMP Alpha? I'm having
great problems even booting the box. The long story is this:

I'm the local admin of goedel.debian.org, a DS20E with two EV68 833
MHz CPUs, a Symbios Logic 53c895 SCSI controller and - because the 4
identical harddisks were rather tempting - a software RAID. With a
vanilla kernel 2.4.2[6-9] it's running fine, although only in
"nosmp"-mode. If both CPUs are active the machine locks up after a
while (like Ryan Murray put it: "processes in memory not touching disk
seem to still run just fine, but as soon as you go to read or write,
you're dead"). So goedel's buildd is using just one CPU... I've tried
all drivers for SYM 53c8xx (IIRC there were at least two), they all
locked up after a while.

My hope was that with the supposedly better SMP-support in kernel 2.6
maybe it would work. However, even booting with "nosmp" did not work
out: either the kernel panics because it can't find it's root-device
and the keyboard doesn't work anymore (no NumLock-reaction, no
scrolling back) or the monitor is loosing sync for a moment and then
I'm back in SRM and can't even read any error messages. I did not find
out when the one or the other happens.

I've tried 2.6.8-2-smp from sarge and 2.6.12-1-alpha-smp from
unstable and did check that the RAID-stuff is inserted into the
initrd. The weird stuff is that the following messages appear (typed
from memory):

RAMDISK: cramfs filesystem found at block 0
RAMDISK: Loading [size of initrd-file] into ram disk
VFS: Mounted root (cramfs filesystem) readonly.
VFS: Cannot find root "md0" or unknown-block(0,0)
panic: ...

So it seems that the initrd is mounted but not used?! As a weird
measure I've omitted root="/dev/md0" from the kernel command line and
got a nice stacktrace and a "Aieee - blah blah interrupt handler"

With 2.6.8-2-smp I once ended up with output resembling #316599 but
that bug's pretty weird: depmod shows no missing symbols when I run it
on this kernels modules... so I don't believe that it's really missing

Could it be some strange effect with the new kernel and the fact that
goedel is connected to a (professional) KVM-switch? I'm asking because
I once had a very cheap PS/2 keyboard SRM didn't like: upon booting
just a blue screen was shown, hitting a lot of keys at once made the
usual SRM-text appear but further typing didn't work. The keyboard
worked fine with other PCs and did when I was using AlphaBIOS on the
same machine (it's escher.debian.org nowadays).

Does anyone have a good idea? Or has experienced something similar?


Attachment: signature.asc
Description: Digital signature

Reply to: