[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: prelink on sarge - busted machine

On Thu, Nov 25, 2004 at 11:54:11PM +0000, Paul Jakma wrote:
> I installed prelink on sarge and unfortunately ended up with a mostly 
> hosed machine where basic utils such as ls, tar, etc, would segfault.

> When I tried to undo the damage, with prelink -un, it did not fix 
> things. Eg, ls would still segfault, even though neither it, nor any 
> of the libraries it is linked to had .gnu_prelink_undo sections 
> (hence - shouldnt be prelinked).

> I had to unpack libc6.1 deb on another machine to an NFS dir, 
> LD_LIBRARY_PATH to its libs and untar the libc data file over 
> existing ones.

> Does prelink have known problems on alpha?

Hmm, perhaps you're the first person who's actually tried to use prelink on

Nope, guess not:


For my part, attempting to run "prelink -a" gives me an immediate segfault,
and this is in a pristine sarge chroot with nothing significant installed at
all.  Since prelink has already been dropped from sparc recently due to
critical breakage, it doesn't surprise me if the same is true on alpha.

Steve Langasek
postmodern programmer

Attachment: signature.asc
Description: Digital signature

Reply to: