[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: AlphaServer 800 Installation

As stated below, I just tried the install boot using sarge, and did not get the “kernel paging request” error.  Perhaps this is because I got a different error.  After finding the aboot.conf file on the CD image, I entered the command as follows:


>>>boot dak400 –fi /boot/vmlinuz –fl “ramdisk_size=16384 initrd=/boot/initrd.gz root=/dev/ram devfs=mount,dall”


(NOTES: I had to use “vmlinuz” because “linux” did not exist on the CD.  I also could not find a “root.bin” for initrd to use, but aboot.conf referenced /boot/initrd.gz so I used it. I also used the ramdisk_size and devfs flags because I got the similar errors without using them.  Without ramdisk_size, it simply gave a different address for the error.  And devfs appeared to do nothing.)


Then I got this error:


VFS: Cannot open root device “” or 08:02

Please append correct “root=” boot option

Kernel panic: VFS: Unable to mount root fs on 08:02


In my mind this means that it could not use /dev/ram to mount the root file system, though I do not know why.  I will continue to try various parameter to see if I can get it to work, but I suspect I will need an expert to point me in the right direction.





-----Original Message-----
From: Jim and Kelly Younkin [mailto:jimandkelly@younkin.com]
Friday, May 28, 2004 8:37 AM
To: debian-alpha@lists.debian.org
Subject: RE: AlphaServer 800 Installation




Thank you ever so much for helping!  I have been struggling now for a week. Here is the extent I can record of the paging error.  There are two screen of data that scrolls by before I can write it down.  If we need that too, you will have to show me how to stop the screen from scrolling (I tried ctrl-s and even the [pause] key but neither stops the screen.


Unable to handle kernel paging request at virtual address 0000000000000010 swapper(1): Oops 0

pc = [<fffffc000046b210>]  ra = [<fffffc000046ce08>]  ps = 0000

v0 = 0000000000000007      t0 = 0000000000000000      t1 = 0000000000000001

t2 = fffffc000ffcc7d0      t3 = 00000000000000f8      t4 = fffffc00001d8160

t5 = fffffc00001f0100      t6 = 0000000000000000      t7 = fffffc000ffc4000

s0 = fffffc00001f0000      s1 = fffffc00005b2f10      s2 = 0000000000000000

s3 = fffffc00005d34a8      s4 = fffffc00005d3434      s5 = 0000000000000000

s6 = 0000008740000000      a0 = fffffc00001f0100      a1 = fffffc00001f0000

a2 = fffffc000ffcc7c0      a3 = 0000000000000001      a4 = 00000000000000a0

a5 = 0000000000000000      t8 = 0000000000000000      t9 = 0000000000000000

t10= 0000000000000000      t11= 0000000000008000      pv = 0000000000000000

at = 0000000000005700      gp = fffffc00005c8be0      sp = fffffc000ffc7df0


     6bfa8001   ret zero,(ra)

     2fe00000   ldq_zero,0(v0)

     a6f00040   ldq t9,64(a0)

     47ff0407   or zero,zero,t6

     23975700   lda at,22272(t9)

     2fe00000   ldq_u zero,0(v0)

    * a0370010   ldl t0,16(t9)

     40e01642   s8addq t6,0,t1

Trace: 3102c0 3102d8 3102c0 310888 3102c0 31085c 310838 3102c0 31085c 3102c0


Helge – I saw on some messages that some people with Alpha boxes had this paging problem when they were using kernel 2.2 and 2.4.  I noted that one person reported the problem did not occur when they used kernel 2.6.  I have downloaded sarge (which I believe uses 2.6) and I plan to try that later today.  Thanks again for your help.



-----Original Message-----
From: Helge Kreutzmann [mailto:kreutzm@itp.uni-hannover.de]
Friday, May 28, 2004 2:54 AM
To: Jim and Kelly Younkin
Cc: debian-alpha@lists.debian.org
Subject: Re: AlphaServer 800 Installation



On Thu, May 27, 2004 at 03:24:20PM -0400, Jim and Kelly Younkin wrote:

> I am trying to install Debian on my AlphaServer 800 and I cannot get

> past the kernel load. I am sure I am doing something wrong, can someone

> help?


Are you using the woody boot floppies installer or the new debian



I have been using Woody CD images.


> When booting from CD (dka400), I have tried using the -flags 0 but I get

> some kind of paging error. Sometimes I get an aboot menu which gives me

> some options for booting. choice 'l' lists "preconfigured kernels" that

> are selected from my aboot.conf file, and I have been choosing '0' which

> is as follows...


Can you try to copy down this paging error? This seems the real cause

of the problem.


Will do…


> 0:boot/linux root=/dev/ram initrd=boot/root.bin


> So here are my questions:

> 1 - Can I assume that "boot/linux" is correct since my CD has a

> directory called "boot" and it contains a file called "linux"? Why does

> my documentation on aboot show "0:3/vmlinux.gz root=/dev/sda3"?


The documentation is just giving examples from "normal" operation.

Depending on the name of the kernel to boot, this line my be

different. But Yes you are right, it looks a little strange. Can you

try (at the aboot prompt):


b /boot/linux root=/dev/ram initrd=boot/root.bin

I used this just now to recreate the paging error I am documenting.


> 2 - How do I know the "root" setting is correct? Should this point to

> the CD or to a harddrive?


During the initial install a ramdrive is used, so this setting is

probably correct. OK


> 3 - I assume "initrd" is some kind of initialization flag, but what does

> it do and how do I know that boot/root.bin is the right setting?


There should be a file /boot/root.bin which contains an INITial

RamDrive, i.e. a small container holding lots of drivers and other

modules. Thanks.


> 4 - I have 256m of memory, and have used the "mem=256m", but I still get

> the kernel paging error. Is this parameter a good idea?


This should not be needed. I don't know if it is even considered at

all. I will ignore.


> 5 - Some of my documentation shows "load_ramdisk=1", which I have also

> tried, but doesn't appear to make a difference. What is it's purpose,

> and should I use it?


I think this was used in the past when you actually applied floppy

disks. I don't think it is in use today still.  I will ignore.


> Getting started with Linux has been extremely frustrating, I don't know

> how you all deal with it. If I cannot get this installed I will probably

> have to go back to M$.


Well, the problem is a)that people usually get M$ preinstalled and

b)you've (unfortunately) run into a strange install error and c)alpha

are different considering booting (though when running they are pretty

similar to i386 linux), so there's an extra hurdle here for the

newcomer.  Agreed.


Please try to post the exact error message about this paging and then

we can better help you.







Helge Kreutzmann, Dipl.-Phys.               Helge.Kreutzmann@itp.uni-hannover.de

  gpg signed mail preferred    gpg-key: finger kreutzm@zibal.itp.uni-hannover.de

    64bit GNU powered                  http://www.itp.uni-hannover.de/~kreutzm

       Help keep free software "libre": http://www.freepatents.org/

Reply to: