[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: AlphaServer 800 Installation



Hello,
On Thu, May 27, 2004 at 03:24:20PM -0400, Jim and Kelly Younkin wrote:
> I am trying to install Debian on my AlphaServer 800 and I cannot get
> past the kernel load. I am sure I am doing something wrong, can someone
> help?

Are you using the woody boot floppies installer or the new debian
installer?

> When booting from CD (dka400), I have tried using the -flags 0 but I get
> some kind of paging error. Sometimes I get an aboot menu which gives me
> some options for booting. choice 'l' lists "preconfigured kernels" that
> are selected from my aboot.conf file, and I have been choosing '0' which
> is as follows...

Can you try to copy down this paging error? This seems the real cause
of the problem. 

> 0:boot/linux root=/dev/ram initrd=boot/root.bin
> 
> So here are my questions:
> 1 - Can I assume that "boot/linux" is correct since my CD has a
> directory called "boot" and it contains a file called "linux"? Why does
> my documentation on aboot show "0:3/vmlinux.gz root=/dev/sda3"?

The documentation is just giving examples from "normal" operation.
Depending on the name of the kernel to boot, this line my be
different. But Yes you are right, it looks a little strange. Can you
try (at the aboot prompt):

b /boot/linux root=/dev/ram initrd=boot/root.bin

> 2 - How do I know the "root" setting is correct? Should this point to
> the CD or to a harddrive?

During the initial install a ramdrive is used, so this setting is
probably correct.

> 3 - I assume "initrd" is some kind of initialization flag, but what does
> it do and how do I know that boot/root.bin is the right setting?

There should be a file /boot/root.bin which contains an INITial
RamDrive, i.e. a small container holding lots of drivers and other
modules.

> 4 - I have 256m of memory, and have used the "mem=256m", but I still get
> the kernel paging error. Is this parameter a good idea?

This should not be needed. I don't know if it is even considered at
all.

> 5 - Some of my documentation shows "load_ramdisk=1", which I have also
> tried, but doesn't appear to make a difference. What is it's purpose,
> and should I use it?

I think this was used in the past when you actually applied floppy
disks. I don't think it is in use today still.

> Getting started with Linux has been extremely frustrating, I don't know
> how you all deal with it. If I cannot get this installed I will probably
> have to go back to M$.

Well, the problem is a)that people usually get M$ preinstalled and
b)you've (unfortunately) run into a strange install error and c)alpha
are different considering booting (though when running they are pretty
similar to i386 linux), so there's an extra hurdle here for the
newcomer.

Please try to post the exact error message about this paging and then
we can better help you.

Greetings

         Helge

-- 
Helge Kreutzmann, Dipl.-Phys.               Helge.Kreutzmann@itp.uni-hannover.de
  gpg signed mail preferred    gpg-key: finger kreutzm@zibal.itp.uni-hannover.de
    64bit GNU powered                  http://www.itp.uni-hannover.de/~kreutzm
       Help keep free software "libre": http://www.freepatents.org/

Attachment: pgpcO_43cJeoF.pgp
Description: PGP signature


Reply to: