[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#242659: d-i errors on alpha

Package: installation-reports
Severity: Normal

an-installer-version: sarge-alpha-netinst.iso daily build from 5. April
uname -a: (don't remember exactly but was 2.4.24)
Date: 07. April 2004
Method: boot from scsi cdrom, target root partition on scsi hard-disc

      Machine: alpha rawhide
      Processor: 4
      Memory: ~ 800 Mb
      Root Device: SCSI Maverick hard disc 

    Base System Installation Checklist:

    Initial boot worked:    [0]
    Configure network HW:   [0]
    Config network:         [0]
    Detect CD:              [E] 1)
    Load installer modules: [0]
    Detect hard drives:     [0]
    Partition hard drives:  [0]
    Create file systems:    [0]
    Mount partitions:       [0]
    Install base system:    [E] 2)
    Install boot loader:    [E] 3)
    Reboot:                 [ ]
    [O] = OK, [E] = Error (please elaborate below), [ ] = didn't
    try it


1) the cd from whom aboot booted the debian system was not recognised:

cat /proc/scsi/scsi
Attached devices:
Host: scsi0 Channel: 00 Id: 05 Lun: 00
  Vendor: DEC	Model: RRD47	(C) DEC	Rev: 1206
  Type:   CD-ROM		ANSI SCSI revision: 02

mount /dev/scsi/host0/bus0/target5/lun0/cd /cdrom

2) base system install aborted with following message on console 3:

  trying to overwrite /etc/default/devpts which is also in packages 
  initscripts .. errors where encountered while processing .*libc6

also tried beta3, but this aborted even earlier in base-install 
with no error message while trying to install libgcrypt

did a reinstall on clean partition and aboves error appeared again.
manually installed all packages witch dpkg inside a chroot

3) at this stage i strongly missed a menu-entry for aboot at d-i!!

   from within the chroot one can't do much
   so i tried a recommendation from an srm howto
   (-> http://www.sgmltools.org/HOWTO/SRM-HOWTO/t182.html)
   did an # swriteboot /dev/sda bootlx vmlinux.gz
   (well different pathes .. but you got it)
   it asked for an -fi in order to overwrite the first empty
   partition, which was given.
   I eventually forgot to setup an /etc/aboot.conf

the installation ended somehow miserably with a working 
debian install (had already an sshd inside) but without
the possibility too boot inside this root partition :(

i tried many possible root flags from within srm,
but the kernel always failed to find the root partition
(also tried boot root partition from cd).

regards maks

Reply to: