[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: radeon dri problems

On Tue, Dec 02, 2003 at 11:42:07PM -0500, Tom Vier wrote:
> what about agpgart? i guess it's needed for the modules in the xfree source

When building the modules that are included in the kernel sources,
there's a dependency (erroneous in Alpha's case) on the AGPGART option
for even asking whether the Radeon DRM module ought to be built.

I believe this is a side-effect of the fact that the Radeon PCI-GART
code did not work on IA32 for a long time, so the powers-that-be made
it generically depend on the AGP-GART option to avoid those
architecture-specific problems... :-\

I don't remember details of the DRM module building when done out of
the XFree86 sources, but seem to recall that there was no such
dependency when coming from that direction...

> i get this:
> Linux agpgart interface v0.99 (c) Jeff Hartmann
> agpgart: Maximum main memory to use for agp memory: 1919M
> agpgart: no supported devices found.

It shouldn't have harmed anything, so those messages can safely be


Jay A Estabrook                            HPTC - LINUX support
Hewlett-Packard Company - MRO1-2/K15       (508) 467-2080
200 Forest Street, Marlboro MA 01752       Jay.Estabrook@hp.com

Reply to: