[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: dcgui



Hi,

Joakim Roubert wrote:
> I was trying to (re)install dcgui (http://dc.ketelhot.de/) on my machine.

Are you running sid?

> checking for Qt... configure: error: Qt (>= Qt 3.0) (headers and
> libraries) not found. Please check your installation!
> For more details about this problem, look at the end of config.log.
> octavia:~/src/dcgui-0.2.1$
> 
> At the end of config.log, all there is is:
> 
> octavia:~/src/dcgui-0.2.1$ tail config.log
> #define SIZEOF_INT 4
> #define SIZEOF_LONG 8
> #define STDC_HEADERS 1
> #define VERSION "0.2.1"
> #define ksize_t socklen_t
> #endif
> #ifdef __cplusplus
> #include <stdlib.h>
> 
> configure: exit 1
> octavia:~/src/dcgui-0.2.1$

You should have posted some more lines, becazse the necessary Qt things
do not appear on that snippet...

> I have tried installing libqt* packages from stable, testing, unstable and

the -dev packages too?

> back and forth to get this working, but I just don't seem to make it.

When you use sid, Tried

QTDIR="/usr/share/qt3" ./configure 

or

./configure --with-qt-libraries=/usr/share/qt3" --with-qt-includes="/usr/share/qt3"

?

Either way should work when you have installed the -dev packages...

Onstalling the -dev packages should already work if you use stable;
specifying the above path isn't neccessary and won't work anyway..

Regards,

Rene
-- 
 .''`.  Rene Engelhard -- Debian GNU/Linux Developer
 : :' : http://www.debian.org | http://people.debian.org/~rene/
 `. `'  rene@debian.org | GnuPG-Key ID: 248AEB73
   `-   Fingerprint: 41FA F208 28D4 7CA5 19BB  7AD9 F859 90B0 248A EB73

Attachment: pgpUPhmyCPHLq.pgp
Description: PGP signature


Reply to: