[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: NetBoot on Multia

Hash: SHA1

> > 	Anyhow, here goes. I?ve got a VX40 Multia, which I?m trying to
> > netboot. I tried stable, no dice. kernel dies and it
> reboots. Then, I
> > tried Woody. It worked. Loads tftpboot.img, I?m able to mount
> > nfs, install the base system. I get an error about chroot
> > /target, but I cancel out, and attempt to finish the install. It
> > locks up
> on reboot.
> > So, then I take my newly loaded Debian install, and try to boot
> > with an aboot padded kernel. Of course, I?m sure you know what
> happens, as
> > the Debian kernels no longer have NFS compiled in, and it
> can?t mount
> > root fs.
> >
> erm, i thought they did.  I always install over nfs ...  (local
> mirror availability and all) and have never noticed the lack of
> support.
> does 'cat /proc/filesystems' contain a line with "nodev nfs"?

?nodev nfs? is in there when I boot off the rescue floppy. What does
that mean?

> another option is to put a local copy of the install files
> (modules, root
> etc) on a disk and transfer that into your multia.  then load the
> nfs module.

I 've made a boot floppy from the Debian install process, and tried
using the rescue floppy, passing arguments as such:

boot -pr bootp ewa0 -flags "root=/dev/nfs nfsroot="

Still can't mount root at 00:00

> > 	NetBSD, OpenBSD, and FreeBSD all are afflicted with the same
> > problem. The kernel can?t get the mac address from the firmware.
> > At
> >
> that seems to indicate more of a hardware problem than a
> software/debian/RH/<OS_here> problem  :(
> try flashing the console with the latest firmware (locations
> available many
> times over in the  archives here and www.linuxalpha.org)

Nope. The problem IS with the latest firmware. 3.8.3 is buggy. 3.8.2
works well, but Digital won?t release it.

> > first, I thought this might of been the problem that potato had,
> > and maybe it did, but it?s fixed now, I guess. I suppose I need
> > to get out a cross compiler and start building.
> >
> only caveat there, is that you *really* want to build your
> alpha binaries
> on a 64 bit machine.  Wierd stuff and broken binaries happens
> otherwise.

Good plan. I think I know someone to help me out. I?ll post status of
woody again later.

Zach Lowry

Version: PGPfreeware 7.0.3 for non-commercial use <http://www.pgp.com>


Reply to: