[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Installing a package interactively

Jim Woodruff wrote:

I'm running a DEC Alpha using Debian 3.0 (unstable). I have downloaded the
libots, cpml-ev5, cxml-ev5, ccc, and cxx rpm packages from Compaq.

When I "apt-get install" the cxx package (assuming it will retrieve all
the dependency files from Debian, it exits with the following error:

"You are running in non-interactive mode and the Compaq needs to prompt ...
Please re-install it in interactive mode."

I've also tried "dpkg -i" with the downloaded Debian packages with the
same results.

I've also tried converting the Red Hat rpm file with alien but it does not
build correctly and the resultant .deb package doesn't install correctly.

How dow I install these packages interactively?

Hmm. I've tried to install both of these ways, and it's worked fine for me; with dpkg, the debconf stuff is done during postinst.

How is debconf configured for you -- which front end?
dpkg-reconfigure debconf
The packages need to interact with the user via debconf, so if you have debconf configured non-interactive, that's the problem...

I'm ccing this to debian-alpha in case folk there are aware of other issues I don't know about. I hope you don't mind...


-Adam P.

GPG fingerprint: D54D 1AEE B11C CE9B A02B  C5DD 526F 01E8 564E E4B6

Welcome to the best software in the world today cafe! <http://lyre.mit.edu/%7Epowell/The_Best_Stuff_In_The_World_Today_Cafe.ogg>

Reply to: