[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Alpha Milo/rescue/root floppies on LX164

On 16 Aug 2001, Falk Hueffner wrote:

> Hmm, could you please file a bug report against tasksel about this?

Certainly. I'll have to find where to file it...

> >  The installer will not write linload.exe and milo to the 5M FAT16
> > partition (/dev/hda1). This may be due to my own incompetence, as it's
> > never worked for me.
> Hm, was there any reason in the log? You can use the "report bug" or
> similar menu entry to save the logs to the floppy. I've not yet tried
> MILO installation, but it *should* work :)

Excerpt from /var/log/installer.log
	Aug 13 21:51:49 (none) user.err dbootstrap[38]: The MILO and APB
	bootloaders must reside on a FAT partition in order to be read by
	ARC/AlphaBIOS firmware.  You appear not to have any DOS FAT partitions.
	This means you will not be able to boot directly from disk.

I do have a 5M FAT16 partition at the head of the drive. I'm fairly
certain it didn't have a filesystem on it at that point. Although that's
not the problem. I'm doing a MILO install on a Multia now and it just
threw the same errors into the log.
 A possible suggestion - disable that for now and give instead
instructions for rebooting; The milo prompt comes back during reboot.
Just hit a key and enter "boot hdaX:vmlinuz root=/dev/hdaX" . Then have
the second-stage installer mount the FAT fs & mcopy the milo floppy to

> There's a "mkdosfs" on the boot floppy, but no menu entry to access it
> so you'd need to use the shell IIRC.  I will document this for now,
> and see if I can hack it to be accessible from the menu.

D'oh! I was looking for mkfs.msdos or "mkfs -t msdos" in the shell.

> BTW, does anybody know if it is possible to launch AlphaBios from SRM
> on an SX164? I know how to *install* it, but for testing purposes it
> would be nice if I could launch it off a floppy.

I dunno about the SX. Assuming it's a half-flash BIOS like the LX, you
could try putting the equivalent of "lx164nt.rom" on a DOS floppy, put
that in the drive and do "fwupdate" at the srm prompt. Works for me....

> > With SRM v5.8-1:
> >  Boots fine from the rescue floppy, installs fine (with the tasksel
> > exception) and then the installed system won't boot. The kernel loads
> > and starts, then gets an error --
> > "ID 1 is respawning too fast, disabling for 5 minutes."
> >  And that's that.

 OOPS!, the respawn thing was my own error. I had the swap partition
starting on the last cylinder of the root partition. Tried again with
better luck.
 However, after doing the MILO install, I went back to try a SRM install
to see if this reproduces (D'oh!), and the installer tried to let me use
the existing partitions. The existing DOS-disklabel partitions. Unless
I'm greatly mistaken, that's A Bad Thing.
 When I chose to "Partition a Hard Disk" instead, then I got prompted to
build an OSF disklabel.

 And is SOP on this list to cc: Everybody throughout a thread? Some
lists do, some don't...
If not, I'll trim the cc: list in future posts.

See ya later,

Reply to: