[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Generic SCSI trouble


I have for a long time been trying to get my CD-R 
to work under Linux, It's a Phillips CDD2600 connected
to an AdvanSys ISA controller. I have compiled in
SCSI support as modules in the kernel. That is to
say; SCSI support, generic SCSI support,
SCSI CD-ROM support and the AdvanSys low
level driver.

All modules seems to load just fine when I use
insmod on them, but if I try an rmmod, it says that
they are not loaded.

At some point in the past, on an older RedHat
system, I was able to get one step furter. xcdroast
(isn't that the name?) actually found a SCSI device,
but was unable to use it.

My first step would be to be able to mount the CD-R
as a CD-ROM. I've tried to mount it using /dev/sg*,
but it complains that that's not a block device (which
is true, at least on my system). I've also tried /dev/scd*,
but it then comlains about wrong major and minor

Also note: on the older system mentioned, 
cdrecord -scanbus yielded some  garbagge
indicating that there was something there, but it
didn't know what. Now, the same command yields

Any help here would be greatly appreciated.

BTW: I'm running Potato on an Alpha with kernel
2.4.5. The older RedHat system mentioned was
RedHat 5.2/6.0 running a 2.2.x kernel (don't
remember exactly which one).

- IT

Reply to: