[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

cfalrtl question


I'm mostly done with the cfal(rtl) installer packages, but there's a
missing symbol "fstat" I can't figure out.  Here's my source:

      program theerf
C     This is the erf program
      write (*,*) 'Hello world'
      write (*,*) 'The error function of 1 is ', erf(1.0)

I build with "fort erf.f -o erf", which goes fine (well, except the
"tempnam" warning), but then when I run it:

% ./erf
./erf: error while loading shared libraries: /usr/lib/libfor.so.0:
undefined symbol: fstat

Where's fstat?

% nm /usr/lib/compaq/cfalrtl-1.1.0/libUfor.a | grep fstat
                 U fstat
0000000000000000 T fstat_
% nm /usr/lib/compaq/cfalrtl-1.1.0/libfor.a | grep fstat
                 U fstat

but the shared libs are stripped, so I don't know if fstat is really in
libUfor.so or somewhere else that gets lumped into the static
libUfor.a.  ldd shows:

% ldd erf
 libUfor.so.0 => /usr/lib/libUfor.so.0 (0x0000020000030000)
 libfor.so.0 => /usr/lib/libfor.so.0 (0x0000020000050000)
 libFutil.so.0 => /usr/lib/libFutil.so.0 (0x00000200000e4000)
 libcpml.so.0 => /usr/lib/libcpml.so.0 (0x0000020000138000)
 libots.so.0 => /usr/lib/libots.so.0 (0x00000200001ca000)
 libc.so.6.1 => /lib/libc.so.6.1 (0x00000200001e8000)
 /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x0000020000000000)
% ls -l /usr/lib/libUfor.so.0
lrwxrwxrwx    1 root     root           31 Apr 12 09:53
/usr/lib/libUfor.so.0 -> compaq/cfalrtl-1.1.0/libUfor.so

(The .0s are there because I put them in the sonames, so packages linked
against them will automatically depend on cfalrtl.  For details: man

I tried buliding with -lfor -lUfor, and that switched the order of these
two in ldd output, but gave the same error.  I tried building with
-Wl,-static but that gave:

% ldd erf
 libUfor.so.0 => /usr/lib/libUfor.so.0 (0x0000020000030000)
 libfor.so.0 => /usr/lib/libfor.so.0 (0x0000020000050000)

Even tried putting /usr/lib/libUfor.a in the compile line, but same ldd,
same runtime error.

So what's the problem here?

Oh- BTW, for some reason the installed fort does *not* ask for license
information before running...  Current package is again at

Thanks in advance,

-Adam P.

GPG fingerprint: D54D 1AEE B11C CE9B A02B  C5DD 526F 01E8 564E E4B6

          Welcome to the best software in the world today cafe!

Reply to: