[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Kernel configuration questions

[diclaimer: I am an Alpha newbie. I know Linux/Debian]


I successfully installed 2.2 on a Alphastation 600 5/266, and tried to
compile a new kernel.

I downloaded the kernel-source-2.2.17 package, and ran the config
script. As I don't want loadable module support (the machine will be
an exposed webserver), I disabled that option. Otherwise I left
everything more or less as it was.

The kernel compiled w/o problems, and I installed it with dpkg.

After a reboot, aboot hung with the line "loading vmlinuz"[1]. I tried
booting with vmlinuz.old, and got the Tux logo. However, I got a
kernel panic when the kernel couldn't find the root disk.[1]

Have I missed something really basic? With i386, I've deselected the
IDE controller, with similar results. But I have support for SCSI
compiled in.

The question is: how can a kernel compile lead to an unusable *old*
kernel? Is there some blindingly obvious thing I missed (this is my
first Debian system with SCSI, likewise my first Alpha.)



[1] what it said exactly is unclear, as I chose to reinstall and try

Gustaf Erikson | <gustafe@home.se> | <http://stureby.net> | +46(0)70-444 0726 
End of .signature reached: message halted.

Reply to: