[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: trouble with NIS in slink update

> In article <cistron.3861180B.63250D96@arxel.si>,
> Ferenc Kiraly  <feri@arxel.si> wrote:
> >I just upgraded to the most recent slink release and NIS stopped
> >working. If I run any of the NIS programs: domainname, ypcat,
> >ypwhich, etc, I get an instant segmentation fault. This is
> >supposed to be a production machine, so no I'm pretty much in deep
> >shit for doing the update. What can I do about it. Is it possible 
> >get the old nis packages somewhere, so I can attempt a downgrade?
> Not that I know of.
> I got one other bugreport about this. I replied that it might
> be the kernel (there's an issue with the FPU emulation in most
> alpha Linux kernels that is mostly solved in 2.2.14pre16) but
> haven't had a reply yet.
> Could you try to compile and boot a 2.2.14pre16 kernel to
> see if that fixes the problem, and post the results here ?

OK, I guess I'm ruling out the kernel problem. I upgraded from
kernel 2.0.38 to 2.2.14pre16 as you suggested and it made
absolutely no difference to NIS. The above mentioned progs
segfault just as happily as ever. So the problem remains.
Anything else I can try? 

NIS did work for me with 2.0.38, before upgrading the
nis package, although a bit strangely. After a reboot it
would be unstable and crash often (but not segfault), but
after several restarts of NIS it would stabilize and work
flawlessly till the next reboot (which I kept to an absolute
minimum -- this alpha had an 265 day uptime).

Anyway I'm leaving the new kernel in place now. The alpha seems
to be even more snappy with it. I think I can actually feel the
improvements :-)


PS: some details about the machine:

cpu                     : Alpha
cpu model               : EV56
system type             : EB164
cycle frequency [Hz]    : 533189504 est.

Reply to: