[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Status of boot-floppies on Alpha?

David Huggins-Daines <dhd@eradicator.org> writes:

> I'm wondering who is currently working on boot-floppies for Alpha at
> the moment and what tasks need to be done.  I have the checked-out
> CVS tree but I actually haven't tried to build them yet - I will do
> so shortly.

I have also tried this; I found some minor (and some major) problems.

The ldconfig package is replaced by ldso:

--- boot-floppies-10.11/scripts/basedisks/PACKAGES_alpha        Sun Oct 10 22:03:54 1999
+++ boot-floppies-10.11-ffh/scripts/basedisks/PACKAGES_alpha    Tue Oct 12 12:14:35 1999
@@ -1,3 +1,3 @@
diff -Nurd -X X.boot-floppies boot-floppies-10.11/scripts/rootdisk/EXTRACT_LIST_alpha boot-floppies-10.11-ffh/scripts/rootdisk/EXTRACT_LIST_alpha
--- boot-floppies-10.11/scripts/rootdisk/EXTRACT_LIST_alpha     Thu Apr 15 01:20:39 1999
+++ boot-floppies-10.11-ffh/scripts/rootdisk/EXTRACT_LIST_alpha Tue Oct 12 12:14:44 1999
@@ -1,4 +1,4 @@

I had to remove a strange declaration to get rid of an even stranger
linker error:

diff -Nurd -X X.boot-floppies boot-floppies-10.11/utilities/busybox/loadfont.c boot-floppies-10.11-ffh/utilities/busybox/loadfont.c
--- boot-floppies-10.11/utilities/busybox/loadfont.c    Sun Jan 24 21:41:47 1999
+++ boot-floppies-10.11-ffh/utilities/busybox/loadfont.c        Tue Oct 12 12:17:42 1999
@@ -44,7 +44,6 @@
 #define PSF_MAGIC_OK(x)        ((x).magic1 == PSF_MAGIC1 && (x).magic2 == PSF_M
 static void loadnewfont(int fd);
-static char *malloc();
 loadfont_main(struct FileInfo *info, int argc, char **argv)

Then I had this problem with lowmemrd:

cc -O2 -Wall -s   -c linuxrc.c -o linuxrc.o
cc -O2 -Wall -s   -c mkswap.c -o mkswap.o
cc -O2 -Wall -s   -c fdisk.c -o fdisk.o
cc -O2 -Wall -s   -c llseek.c -o llseek.o
cc -O2 -Wall -s -static -Wall -o linuxrc linuxrc.o mkswap.o fdisk.o llseek.o ../libfdisk/libfdisk.a /usr/lib/libz.a
collect2: ld terminated with signal 11 [Segmentation fault], core dumped
make: *** [linuxrc] Error 1

When removing the '-static', it works. I have no idea what to do, but
I'm not sure lowmemrd is really needed for Alpha anyway... Were there
alphas at any time with < 16 MB RAM? The lowest I've ever heard was

The stuff for building the different rescue kernels seems to be
missing, right?

I really wonder if building ~10 different rescue disks is needed at
all since newer kernels have a 'generic' target. The help says it will 
run on any supported system, only slower. Well, people will compile
their own kernel anyway so that shouldn't be a problem.

So I suggest we try to find out whether using generic kernels could be 
used and then convert the Makefile to do so. Since there seems to be
no kernel-image package for Alpha, one could require a kernel source
to be lying around and copy the config there.

Well, building root.bin seemed to work (after I noticed I have to
install ash...), but if I chroot into it I get

/bin/sh: error in loading shared libraries: /bin/sh: symbol sys_siglist, version GLIBC_2.1 not defined in file libc.so.6.1 with link time reference

should chrooting work? I'll try booting with it later.

Note: I've added the debian-boot list to the recipients.


Reply to: