[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Ramdisk for Jensen

At one point the debian kernel needed a ramdisk_size=5120 boot parameter. Could it be that? 

To try test this you want to: 
  >> boot -fl "i"
  aboot> 0/a root=/dev/fd0 load_ramdisk=1 ramdisk_size=5120 prompt_ramdisk=1

I would recommend that you try the files from:

	ftp://ftp.azstarnet.com/pub/axp/Jensen/install (which was unresponsive)

or its mirror:


They worked for me. I got the same error messages you're getting when I used the kernel from the DEC site. My problem was a ramdisk problem, although I thought it was at first. I described it in an earlier message to this list, enclosed below.

 - Peter Mott

Date: Mon, 07 Dec 1998 11:20:23 -0500
To: ESP <evangelo@pigdog.org>, debian-alpha@lists.debian.org
From: Peter Mott <mott@mathworks.com>
Subject: Jensen installation (was: 981115 jensen/resc1440.bin image bad?)

I have just completed installing linux on a Jensen. Below is a pointer the Jensen-HOWTO that worked for me. To make this installation work I actually dedicated a disk to aboot, because the RedHat 5.0 installation process wanted an fdisk style partition table on the target installation hard disk, while the aboot tools create a BSD partition table, needed by the SRM console to boot. I could not easily make these co-exist. 

I'd like to go through a debian installation, instead of RedHat. Give me the pointers to what you are using, and I'll go through the installation too.

(LOOKING FOR partition table documentation: Anyone have pointers to documentation on the disk structures and physical blocks used for these two partition tables?)

(LOOKING FOR fdisk/aboot coexistence: If someone knows how to get aboot to co-exists with an fdisk partition table I'd like to have a hint. The issue being a compatibility between what the SRM console needs to load aboot and the fdisk style partition table.)

Here's the location where I got tools and a Jensen-HOWTO that worked for me. (The tools I got from the DEC site failed at the point of loading the ramdisk.)

ftp://ftp.azstarnet.com/pub/axp/Jensen/install (which was unresponsive) or 

Good luck. If you use these instructions and trip over something, drop me a note I may have seen it.

- Peter Mott

At 12:38 PM 12/14/98 -0800, you wrote:
>I am trying to install Debian on my Jensen.  I followed the instructions at:
>ftp://gatekeeper.dec.com/pub/Digital/Linux-Alpha/JENSEN_INSTALL/Jensen-HOWTO and
>eventually was able to get to step "6B When prompted, insert the ramdisk
>floppy".  I inserted the disk made from
>http://lhpca.univ-lyon1.fr/axp/bf981115/root1440.bin.  I created the ramdisk
>with the following command from another linux machine: 'dd if=root1440.bin
>of=/dev/fd0 bs=18k'.
>Given this prompt on the Jensen: "VMS Insert root floppy disk to be loaded into
>ramdisk and press ENTER", I inserted the above mentioned disk and pressed ENTER.
>I see this line:
>Ramdisk: Compressed image found at block 0
>then I get a screen full of these messages:
>end_request: I/O error, dev 01:00, sector 5952
>end_request: I/O error, dev 01:00, sector 5954
>end_request: I/O error, dev 01:00, sector 5996
>end_request: I/O error, dev 01:00, sector 5998
>followed by nothing...
>I tried several different methods of creating the disk on several different
>machines.  I tried different diskettes.  Any ideas about what might be causing
>this?  Thanks.
>- C
>To UNSUBSCRIBE, email to debian-alpha-request@lists.debian.org
>with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Peter Mott     |  mailto:mott@mathworks.com  |  Voice: 508.647.7375
               |  http://www.mathworks.com   |    FAX: 508.647.7002
PGP fingerprint: AAB3 CC97 3045 15F1 A9CC  ECA2 0207 FB0A 0997 8F31

Reply to: