[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

X troubles


Several strange X things.


$ xterm &
[1] 3714
$ Warning: locale not supported by Xlib, locale set to C
Warning: X locale modifiers not supported, using default
Failed to open input method

but xterm then seems to work fine.

Second is relating to fonts.  What's strange is that if I run one of
the programs I'll talk about below on a remote machine, with DISPLAY
set to my Alpha, they'll work fine.  If I run them on the Alpha,
they'll crash.  I've got all the latest X packages from binary-alpha,
plus the 6.1 packages from Incoming.

The problem is that some programs just cannot for the life of them
seem to find their fonts.  I've got all the xfonts-* packages
installed, and made sure mkfontdir got run.

The trouble is that some programs have font troubles, some do not.
xfontsel, for instance, works fine.  FreeCiv is one with troubles.  I
tried recompiling with -O only, no fix.  Tk programs seem to work
fine.  Most programs are OK.  wmaker refuses to start, complaining
that it can't find various helvetica fonts that xfontsel can find.
freeciv dumps core after complaining about being unable to load a
fontset.  One program couldn't find "fixed".  Ideas?

John Goerzen   Linux, Unix consulting & programming   jgoerzen@complete.org |
Developer, Debian GNU/Linux (Free powerful OS upgrade)       www.debian.org |
Visit the Air Capital Linux Users Group on the web at http://www.aclug.org

Reply to: