[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Error from libc6.1-dev

Christopher C Chimelis wrote:
> The memory violation happens with some development kernels (I've noticed
> this on on dev kernels so far).  As for what it's trying to overwrite...
> Modutils comes with it's own kerneld.h for /usr/include/linux since
> development kernels lack it (they now have kdev, I believe).  Apparently,
> installing libc6.1-dev tries to overwrite the directory itself instead of
> just adding files to it.  This will be addressed when we get
> libc6.1-2.0.7t packaged (hint hint...fingers crossed).  Probably your best
> solution for now is to either use --force-overwrite with dpkg and
> reinstall modutils afterwards or remove modutils and reinstall it after
> libc6.1-dev.

I was receiving the exact same errors with many packages.  It seemed
that every time dpkg tried to overwrite a file it seg faulted.  What I
did was to install one package, then go and rename the file that tried
to be overwritten and installed the second package.  dpkg still behaved
strangely after I did this (at one point it said that it couldn't
overwrite the directory with the name of a file I had renamed and seg
Well, I eventually got everything installed and chalked the problem up
to the fact that I was using a copy of the distribution from late June
(when i386 went into beta 2).  As far as a kernel goes, I was using the
1998-07-05 boot disks (those were nice! I just have to remember to ftp
in binary, not ascii :) )  In any case, My system is now up and running
great (much better than the redhat 5.0 dist that came preinstalled). 
Oh, and like the other occurence of this seg fault problem, I am using
an lx 533MHz machine.

(sorry if this comes through in HTML or a single line, I long to once
again use pine, just one more day and I can...)

Ryan de Jonckheere

Reply to: