[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Success report.

On Mon, 27 Oct 1997, Doug DeJulio wrote:

> I've just switched my UDB over from running a 2.0.X-series kernal to a 2.1.X
> series kernel.  Some of the problems I had been having magically went away.
> In particular, the distribted PPP started to work, as did the "more" utility.

Hmmm...while I've never tried PPP on my box, I had no problem with the
"new" more command once I packaged util-linux-2.7.1, even under 2.0.30.  I
haven't tried 2.0.31 due to lack of interest (honest reason), so I can't
speak for that kernel.

> Do we want the distribution to work with 2.0 kernels?  I can see "no" being
> considered a reasonable answer -- what's the consensus?

I would tend to say no tentatively, IMPO.  If the 2.1 kernels are still
going to be in development iterations for longer than we expect this whole
process to take, then I would say let's boot back down to 2.0 and work on
it.  However, the x86 people are having some big issues with the glibc
upgrade (all we need to do most of the time is recompile...they're
learning how to port again...what a reverse from a few months ago).  I
doubt they'll resolve alot of their problems in a few months and I
personally expect the development kernels to achieve "release" status
before then.  So, I believe we probably should target for the 2.1.x
kernels.  They provide us with some MUCH needed features (better
integration of Alpha-related patches and the RTC driver to name two) and
also kinda emphasises that this is still a development/unstable-status

Also, on a slightly historic note, the Alphas were the first to go with
the glibc snapshots initially, so it kinda makes strange sense to forge
ahead a bit again to "shake down" the kernel and "shake out" the problems
before we end up dealing with them again, especially if we don't
anticipate an official Debian "release version" between now and the
changeover from development to release kernel.

> If so, I'll reboot back into 2.0 and compile a list of what starts to fail
> again.  If instead 2.1+ is going to be required, we need a set of 2.1+-based
> install floppies (which I can only test on the UDB).  Are the 1997-10-05
> kernels 2.1? 

As far as I know, the install floppies are still 2.0.30.  Then again, I
only know what I've read :P  I would say that it would be really nice to
know what fails under 2.0 (I can think of a few things that should, but
nothing that can't be fixed in five minutes with a quick edit and
repackaging) if for nothing else but reference.  If everyone here agrees
that 2.0.x should be our "release" kernel of choice for now, though, then
by all means, let's find out what's going on and fix it soon :)

> (Now I'm going to go test something I've *never* seen work on an Alpha but
> which I've used succesfully on Intel boxes -- the bsd_comp module for PPP.) 

I'm curious about that too...especially between two platforms.  From the
code, it should be fine, but I'm curious to see if any unaligned trap
warnings pop up or any imcompatibilities that may not have been
compensated for in the code.

Over all, I'm glad to hear that things are working for you :)


TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-alpha-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: