[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Packages with bad dependencies


While I was installing, I took a snapshot of the debian-alpha stuff on

I've written a little script to find packages with bad dependencies.  I'm
sure it can be improved - the "bad dependencies" I've picked up are on
libc5{,-*}, libc6{,-*}, libgdbm1* .  Is this list correct - is libc6-dev a
bad dependency?


#! /bin/sh
# findold - find .deb files depending on old packages
# Nikhil Nair <nnair@debian.org>, 28 September 1997
# This script examines all .deb files in the current directory or in
# subdirectories.

find . -name '*.deb' -print | \
sed -e 's:^\./::' | \
  while read file
    dep=`dpkg-deb -f $file pre-depends depends`
    echo $dep | grep -q libc5 || \
      echo $dep | grep -q 'libc6[^\(\.1\)]\|libc6$' || \
      echo $temp | grep -q libgdbm1 || \
    echo "Filename: $file"
    echo "$dep"

exit 0


The output from the master tree is below.  Maybe these should be retired,
even if replacements aren't yet available?  We don't want these to
propagate ...



Nikhil Nair
Trinity College, Cambridge, England
Tel.: +44 1223 368353
Email: nn201@cus.cam.ac.uk


Filename: base/ncurses-bin_1.9.9e-1.deb
DEPENDS: ncurses3.0, libc5
PRE-DEPENDS: ncurses3.0, libc5

Filename: base/sysvinit_2.70-1.deb
Pre-Depends: libc5 (>=5.2.18-2)

Filename: base/libdb1_1.85.2-8.deb
Depends: libc6

Filename: base/libgdbm1_1.7.3-11.deb
Depends: libc5 (>=5.2.16-1)

Filename: base/ldso_1.7.14-2.deb
Depends: libc6, ldconfig

Filename: devel/libgdbmg1-dev_1.7.3-22.deb
Depends: libgdbmg1, libc6-dev

Filename: devel/slang0.99.34-dev_0.99.38-1.deb
Depends: libc6.1 (>= 2.0.1-0), libc5-dev

Filename: devel/ncurses3.0-pic_1.9.9e-1.deb
DEPENDS: ncurses3.0, ncurses3.0-dev, libc5-dev

Filename: devel/ncurses3.0-dev_1.9.9e-1.deb
DEPENDS: ncurses3.0, libc5-dev

Filename: devel/libbsd_5.2.18-1.deb
Depends: libc6-dev

Filename: devel/gcc_2.7.2-8.deb
DEPENDS: libc5 (>=5.2.18-5), binutils (>=2.6-2)

Filename: devel/visual-tcl_1.07-2.deb
Depends: libc5 (>= 5.4.7-7), tcl76 (>= 7.6-1), tk42 (>=4.2-1), elf-x11r6lib

Filename: doc/libc6-doc_2.0.4-1.deb
Depends: libc6 (=2.0.4-1)

Filename: admin/boot-floppies_1.2.23.deb
Depends: libc5-pic, ncurses3.0-pic, mkrboot, dosfstools (>>1.0-4), syslinux (>= 1.30), sysutils, makedev (>=1.6-15)

Filename: libs/ncurses3.0_1.9.9e-1.deb
DEPENDS: libc5

Filename: interpreters/cpp_2.7.2-8.deb
DEPENDS: libc5 (>=5.2.18-5)

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-alpha-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: