[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Urgent: where to find things?

* Debian on the Alpha

.* ==================== "Ian Willmott" <willmott@nortel.ca> Technique
Put your hard drive into a Linux/Intel box.
Set up root and swap partitions; run mkswap and mke2fs.
Mount the root partition somewhere.
Copy vmlinux.gz onto the root partition.
Untar base.tgz onto the root partition.
Setup /etc/fstab and /etc/hostname . ( /etc/passwd ? )
Put the drive in the Alpha box and boot.
.  - Where did the floppies for this installation procedure come from?
.  - Answer:
.  - What if you have a floppy on your Alpha? Can you boot from that?

.* ==================== "Gregory P. Smith" <smithgr@nagita.cs.colorado.edu>
The installation procedure described by Ian Willmott
(willmott@nortel.ca) a few days ago works!  Here is a log of what I did
to get my Noname AxpPCI-33 system working.

  notes ...


I flashed MILO from RedHat 4.2 into ROM using the Failsafe boot from
floppy jumper to load the initial MILO to do the flash.

disks/               -- contains February 25th 1997 base.tgz
vmlinux.gz           -- taken from the RedHat 4.2 distribution

I extracted base.tgz onto a Zip disk with one partition formatted as
ext2.  I copied vmlinux.gz off of the ext2 format noname.img boot floppy
for RedHat 4.2 and put it on the Zip disk.

At the MILO prompt I did a "boot sdb1:vmlinuz.gz root=/dev/sdb1" and
Debian 1.1 came up to a prompt!
.  - What is the exact command(s) you used to format the zip drive as
.  - What architectures can we expect the AlphaLinux base Debian distribution
     to work on? Where does the AlphaLinux base Debian distributin exist?
.  - Where did you get MILO?
.  - Answer:
.   : Binaries
.   : Documentation

.* ==================== Kari Davidsson <d154402@cs.tut.fi>

Did the floppy install yesterday on my 166MHz UDB with 24Mb ram (2*12M),=20
500Mb internal SCSI, 1Gb external SCSI and TGA graphics adapter.
Everything went smooth. Only problem is that reboot (option O) does
not reboot but Pasi had allready pointed that one out. I ran dselect
and installed all the packages it wanted to install. There was a
problem in the end with two packages (ahh, now I don't remeber their
names), but that is irrelevant to Pasis work anyway. Probably the
system is not up to many things after the deselect-installation phase,
(pasi said it might by "unusable"). I did not have time to try it out,
this was a install-and-run-away thing 8-). I will play more with it
tonight, and let you all know if I find anything worth mentioning.

The system after running deselect was "unusable". Too many things were
broken. Did the floppy install again and skipped the dselect phase and
installed packages manually. The only thing that I found to be tricky
was the netpart. netstd_2.13-1 seem to by unusable, the programs from
it like telnet and ftp report "Network unreachable" or something like
that. Installed a older version of netstd (2.6 i think). This netstd
requeres libc6 (seen e.g. when ldd telnet is run) so I installed
libc6 (don't remeber the version) and the programs from netstd started
to run and behave correctly. There were lot of warnings consernig=20
locale files (and possibley other files too), which are also part of=20
the libc6.1. Those are just warnings and seem to be harmless. The
network was never unreachable route and ifconfig showed that and lynx
worked flawlessly, hence I must conclude problems with netstd 2.13.
The development packages (such as gcc, the devl. libs and more) are
another story. I managed though to get somehow working devel. system
but I doubt that it is working 100% correct.
.  - Where did you get your floppies?
.  - Answer:
.  - Is this different from the install Ian Wilmott described? If so,
     where is it documented?

.* ==================== Pasi Pirhonen <upi@gorba.lpt.fi>
As i promised, at least to someone, yesterday, i'll put available
the work i have done for 'installation kit'.
I really think that it's not finnished, but it's at least a start.

it's available in ftp://gorba.lpt.fi/debian/disks-alpha/current/


- get a MILO for your system and read some docs, for example 
http://www.redhat.com/support/docs/rhl/RHL-4.2-Users-Guide-HTML/ \

- boot the rescue with

MILO> boot fd0:vmlinux.gz root=/dev/fd0 load_ramdisk=1

- follow the instructions and you are done, but the current 'reboot' doesn't
do the job, so press 'ctrl-alt-del' in suitable moment and you'll get MILO-
prompt again.

- boot your system from HD with the vlinux.gz in it.

If you are using the dselect, you'll end up quite unusable system as
there are too many libc6 dependend packages in the hamm/hamm/binary-alpha.
Actually first package the dselect grabs IS libc6 :(

At least i don't remeber, as writing this, anything else.

The kernel includes the patch from
Who knows, what patches 2.0.30/axp _really_ needs?

The rescue for noname doesn't include TGA or MSS, but i am compiling
one as i write this. I'll test it in my noname and if it's working,
i'll replace the generic noname with the multia-compatible one (one hour or so).

The current kernel has NCR8XX (bsd) and Qlogic ISP for SCSI (as i got signal 6
from Buslogic drivers) and NE*000, DE4X5 and TULIP for netowrk. There
is also IDE support in the kernel. CDROM is enabled for IDE/SCSI and there
is TAPE enabled for SCSI too.

PPP is in the kernel and IP-forwarding is enabled, but i don't know if that
is working at all.

In prosess generating those floppies, i have been desperate many times, but
the feeling you get after it's working, wipes everything away :) Let this
be my first contribution for NET community, but not the last one. I have
been using 'free' software for years and all the time looked for way to
pay back .....

ftp://gorba.lpt.fi/debian/binary-alpha/		(mine)
ftp://debian.med.miami.edu/pub/mdorman/		(Michael Dorman)

for some upgraded packages. I think most of needed packages are in one
of above sites. There might be more sites, but i'm not aware of those.

I forgot to mention the specs of my 'reference system'

Noname AXPpci 33/166 (onboad IDE/NCR810 etc.)
Trio 64V+
NE2000/PCI clone (Realtek chip)
32MB RAM + 256k cache
SCSI disks

At least it's working with those specs .......

.* ==================== QUESTIONS
. + GCC
.  - as long as we remove optimization, is it stable?
. + General Linux Question
.  - are swap files created via mkswap as efficient as the ones
     created when assigning a swap partition during Linux setup?

o============o  Sending unsolicited commercial e-mail (UCE)  to this address
 Legal Notice   is indication of your consent to pay me $120/hour for 1 hour
o============o  minimum for professional proofreading & technical assessment.
  Terrence Brannon * brannon@surf.usc.edu * http://quake.usc.edu/~brannon

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-alpha-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: