[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

editing files using VIM on remote server

Hi all,

I’m new to the list and  this is my first post here.

Please excuse me if my question is off topic.

Currently, my job requires me to use cent OS on IBM power PC. And  I’m having a nightmare editing files using SSH on remote server.

The issue is when I press down arrow the cursor goes to next line,. But the screen reader still reads out the last line.


Just let me explain.

Let’s assume


We have following lines in a text file


Line 1

Line 2

Line 3



When I Press I, I’m on the first line.

Press down arrow, goes to next line (line 2), but still reads out line 1.

Press down arrow again, goes to third line (line 3), now it reads out line 2.

Press down arrow, already on third line. I Hear the bell and it reads out the third line.




So far, I tried these things.

  • Used built-in SSH client of windows 10
  • Used SSH in WSL in ubuntu
  •   installed Debian 10 as dual boot and  tried SSH
  • Used different editors text VI, VIM and nano



Everything has failed. Could someone please help me out?

Or just point me to right direction.




I’ll really appreciate any help.


Best wishes


Reply to: